Project

General

Profile

Bug #5943

Installer shows failure message though everything went well with minor exception

Added by Brad Buckingham about 8 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Installer
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1099498
Description of problem:

For a while now the installer has always shows the following two errors:

/Stage[main]/Candlepin::Database/Postgresql::Server::Db[candlepin]/Postgresql::Server::Role[candlepin]/Postgresql_psql[CREATE ROLE "candlepin" ENCRYPTED PASSWORD 'md5b27d86c15ae303d48c52be1948e49e98' LOGIN NOCREATEROLE NOCREATEDB NOSUPERUSER CONNECTION LIMIT -1]: Failed to call refresh: Error executing SQL; psql returned 256: 'ERROR: role "candlepin" already exists
/Stage[main]/Candlepin::Database/Postgresql::Server::Db[candlepin]/Postgresql::Server::Role[candlepin]/Postgresql_psql[CREATE ROLE "candlepin" ENCRYPTED PASSWORD 'md5b27d86c15ae303d48c52be1948e49e98' LOGIN NOCREATEROLE NOCREATEDB NOSUPERUSER CONNECTION LIMIT -1]: Error executing SQL; psql returned 256: 'ERROR: role "candlepin" already exists

However, this had not prevented the installer from ending successfully and has been mostly ignored. Yesterday, there were some new changes done to the installer and now these errors cause it to output the following message:

Something went wrong![0m Check the log for ERROR-level output
The full log is at [1m[36m/var/log/katello-installer/katello-installer.log

The server is up and running but this message is stating the opposite.

Version-Release number of selected component (if applicable):

  • apr-util-ldap-1.3.9-3.el6_0.1.x86_64
  • candlepin-0.9.7-1.el6_5.noarch
  • candlepin-scl-1-5.el6_4.noarch
  • candlepin-scl-quartz-2.1.5-5.el6_4.noarch
  • candlepin-scl-rhino-1.7R3-1.el6_4.noarch
  • candlepin-scl-runtime-1-5.el6_4.noarch
  • candlepin-selinux-0.9.7-1.el6_5.noarch
  • candlepin-tomcat6-0.9.7-1.el6_5.noarch
  • elasticsearch-0.90.10-4.el6sat.noarch
  • foreman-1.6.0.8-1.el6sat.noarch
  • foreman-compute-1.6.0.8-1.el6sat.noarch
  • foreman-gce-1.6.0.8-1.el6sat.noarch
  • foreman-libvirt-1.6.0.8-1.el6sat.noarch
  • foreman-ovirt-1.6.0.8-1.el6sat.noarch
  • foreman-postgresql-1.6.0.8-1.el6sat.noarch
  • foreman-proxy-1.6.0.5-1.el6sat.noarch
  • foreman-selinux-1.6.0-2.el6sat.noarch
  • foreman-vmware-1.6.0.8-1.el6sat.noarch
  • katello-1.5.0-24.el6sat.noarch
  • katello-ca-1.0-1.noarch
  • katello-certs-tools-1.5.5-1.el6sat.noarch
  • katello-installer-0.0.40-1.el6sat.noarch
  • openldap-2.4.23-32.el6_4.1.x86_64
  • pulp-katello-plugins-0.3-1.el6sat.noarch
  • pulp-nodes-common-2.4.0-0.16.beta.el6sat.noarch
  • pulp-nodes-parent-2.4.0-0.16.beta.el6sat.noarch
  • pulp-puppet-plugins-2.4.0-0.16.beta.el6sat.noarch
  • pulp-puppet-tools-2.4.0-0.16.beta.el6sat.noarch
  • pulp-rpm-plugins-2.4.0-0.16.beta.el6sat.noarch
  • pulp-selinux-2.4.0-0.16.beta.el6sat.noarch
  • pulp-server-2.4.0-0.16.beta.el6sat.noarch
  • python-ldap-2.3.10-1.el6.x86_64
  • ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
  • ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
  • ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
  • rubygem-hammer_cli-0.1.0-13.el6sat.noarch
  • rubygem-hammer_cli_foreman-0.1.0-13.el6sat.noarch
  • rubygem-hammer_cli_foreman_tasks-0.0.2-6.el6sat.noarch
  • rubygem-hammer_cli_katello-0.0.3-24.el6sat.noarch

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:


Related issues

Is duplicate of Katello - Bug #5012: Candlepin role already existsClosed2014-04-01

Associated revisions

Revision ba9fd64b
Added by Eric Helms almost 8 years ago

Merge pull request #69 from ehelms/fixes-5943

Fixes #5943: Point at upstream postgresql module to prevent Candlepin DB...

History

#1 Updated by Brad Buckingham about 8 years ago

  • Triaged set to Yes

#2 Updated by Eric Helms almost 8 years ago

  • Status changed from New to Assigned
  • Assignee changed from Ivan Necas to Eric Helms
  • Target version set to 45

#3 Updated by Eric Helms almost 8 years ago

  • Is duplicate of Bug #5012: Candlepin role already exists added

#4 Updated by Eric Helms almost 8 years ago

  • Status changed from Assigned to Duplicate

#5 Updated by Eric Helms almost 8 years ago

  • Legacy Backlogs Release (now unused) set to 13

#6 Updated by Eric Helms about 7 years ago

  • Legacy Backlogs Release (now unused) deleted (13)

#7 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF