Project

General

Profile

Bug #6045

deleting a class fails

Added by m w almost 5 years ago. Updated almost 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Database
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

When trying to delete a class from the puppetclasses screen, this error is produced and the class is not deleted:

PGError
ERROR: update or delete on table "puppetclasses" violates foreign key constraint "environment_classes_puppetclass_id_fk" on table "environment_classes" DETAIL: Key (id)=(1312) is still referenced from table "environment_classes".
app/controllers/puppetclasses_controller.rb:41:in `destroy'
app/models/concerns/foreman/thread_session.rb:33:in `clear_thread'
lib/middleware/catch_json_parse_errors.rb:9:in `call'


Related issues

Is duplicate of Foreman - Bug #4379: Foreign key constraint error on deleting a classResolved2014-02-18

History

#1 Updated by Dominic Cleal almost 5 years ago

  • Is duplicate of Bug #4379: Foreign key constraint error on deleting a class added

#2 Updated by Dominic Cleal almost 5 years ago

  • Status changed from New to Duplicate

Thanks for the report, this is tracked under #4379.

Also available in: Atom PDF