Project

General

Profile

Bug #6053

Deleting Organization raises error

Added by Daniel Lobato Garcia almost 8 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Category:
Orchestration
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1100311
1) Create an Org
2) Create an Activation Key
3) Delete the Org
4) Note error:

Error
Katello::Resources::Candlepin::ActivationKey: 404 Resource Not Found {"displayMessage":"ActivationKey with id 8a889e7e4620dab7014620ecf7a70010 could not be found.","requestUuid":"8315eb6d-ff88-4721-9a56-7e42734ce54e"} (DELETE /candlepin/activation_keys/8a889e7e4620dab7014620ecf7a70010)


Related issues

Is duplicate of Katello - Feature #6180: Implement org destroyClosed2014-06-12

History

#1 Updated by Eric Helms almost 8 years ago

  • Category set to Orchestration
  • Target version set to 45
  • Triaged set to Yes

#2 Updated by David Davis almost 8 years ago

I tested this. Activation keys do get into candlepin on create and when deleting them (without deleting an org) they get deleted properly.

However, when deleting an org that has an activation key, this is the order of calls to candlepin:

1. DELETE request: /candlepin/owners/ACME_Corporation
2. DELETE request: /candlepin/activation_keys/ff80808146721aa40146809f2751006e

I checked the candlepin database and sure enough, the org and key are gone (ie step 1 is deleting the key). Then in step 2 we hit the 404 from candlepin.

The only way to solve this I think is to change the code to use dynflow.

#3 Updated by Eric Helms almost 8 years ago

#4 Updated by Eric Helms almost 8 years ago

  • Target version changed from 45 to 48

#5 Updated by David Davis almost 8 years ago

  • Status changed from New to Duplicate

#6 Updated by David Davis almost 8 years ago

#7 Updated by David Davis almost 8 years ago

#8 Updated by Eric Helms almost 8 years ago

  • Legacy Backlogs Release (now unused) set to 13

#9 Updated by Eric Helms about 7 years ago

  • Legacy Backlogs Release (now unused) deleted (13)

#10 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF