Project

General

Profile

Bug #6058

FireFox open detail of template twice

Added by Dominic Cleal over 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1104147
Description of problem:
When we want open (button "edit") a template detail from the detail of host, FireFox opens two panels with the same detail of the template.
I detected this problem on Firefox and Opera, Chrome is OK.

Version-Release number of selected component (if applicable):
Satellite-6.0.3-RHEL-6-20140528.4

How reproducible:
100%

Steps to Reproduce:
1. We have got Satellite 6 with a provisioning guest (in my case EC2 guest).
2. Open detail of guest ("Hosts" > "All hosts" > our guest > "Templates"
3. We can see templates (in my case "finish Template" and "provision Template")
4. Click on the button "edit"
5. Firefox (or Opera) opens new tab with detail of template twice.

Actual results:
two panels with detail

Expected results:
one panels with detail

Additional info:


Related issues

Related to Foreman - Bug #8822: Template history show diff link opens two tabs in FirefoxClosed2015-01-02
Has duplicate Foreman - Bug #9451: About page opens duplicate tabs for each link you clickDuplicate2015-02-18

History

#1 Updated by Dominic Cleal over 5 years ago

  • Category set to Web Interface

#2 Updated by David Schmitt over 5 years ago

Happens with safari too.

#3 Updated by Pablo Escobar almost 5 years ago

I see the same behaviour when browsing the template history.

When I click in the "show diff" link two new tabs are open. In both tabs the diff is shown correctly but I alwasy get two new tabs.

I have seem the same behaviour in Firefox 33.0 (Linux) and Firefox 32.0.3 (Mac)

#4 Updated by Tomer Brisker almost 5 years ago

Could not reproduce with FF34 on linux with current develop branch.

#5 Updated by Dominic Cleal almost 5 years ago

  • Status changed from New to Resolved

Agreed, seems to have disappeared. The show diff issue remains though, so I've logged it separately as #8822.

#6 Updated by Dominic Cleal almost 5 years ago

  • Related to Bug #8822: Template history show diff link opens two tabs in Firefox added

#7 Updated by Dominic Cleal over 4 years ago

  • Has duplicate Bug #9451: About page opens duplicate tabs for each link you click added

#8 Updated by Bryan Kearney over 4 years ago

  • Bugzilla link changed from 1104147 to 1186942

Also available in: Atom PDF