Project

General

Profile

Feature #61

Add Microsoft DNS Support

Added by Ohad Levy almost 11 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
DNS
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Related issues

Is duplicate of Smart Proxy - Feature #3991: dnscmd provider for smart-proxy (Windows)Closed2014-01-10
Is duplicate of Foreman - Feature #1685: Windows DNS: Secure connection using GSS-TSIGClosed2012-06-14

History

#1 Updated by Ohad Levy almost 10 years ago

  • Project changed from Foreman to Smart Proxy
  • Category changed from DNS to DNS
  • Target version deleted (0.3)

#2 Updated by Paul Kelly over 9 years ago

  • Status changed from New to Feedback

This support is provided by the ISC DNS smart-proxy code. It works on both ISC and Microsoft servers.

Is there some additional work required on this ticket?

#3 Updated by Ohad Levy over 9 years ago

  • Status changed from Feedback to Closed

#4 Updated by Ohad Levy over 9 years ago

  • Status changed from Closed to Feedback

would it be possible to use a windows host to update ms dns as well?
(i.e. equiv of nsupdate but from a pure windows setup).

#5 Updated by Ohad Levy over 9 years ago

just for documentation sake... if your Active Directory zone is restricted (e.g. secure updates only) the current approach will not work.

#6 Updated by Dmitry Sakun almost 7 years ago

It's good to have dnscmd/powershell support on the windows foreman proxy side rather then using nsupdate which creates dynamic DNS record (if scavenging is turned on these records will be removed from DNS and that's not what you to happen for a productive server)

#7 Updated by Dominic Cleal over 6 years ago

  • Is duplicate of Feature #3991: dnscmd provider for smart-proxy (Windows) added

#8 Updated by Dominic Cleal over 6 years ago

  • Is duplicate of Feature #1685: Windows DNS: Secure connection using GSS-TSIG added

#9 Updated by Dominic Cleal over 6 years ago

  • Status changed from Feedback to Resolved

#1685 implemented GSS-TSIG support for the secure updates issue (albeit only dynamic updates via nsupdate), and #3991 has implemented dnscmd support.

Also available in: Atom PDF