Project

General

Profile

Bug #612

Host#configTemplate does not work as expected

Added by Paul Kelly over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Host creation
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Maybe this is my misunderstanding but when I create a host with a hostgroup that does not have template with that hostgroup or hostgroup/environment combinations this method raises an exception.

If I set a configTemplate to use the hosts's hostgroup then the template is found.

Basically it does not lookup the os_default_template correctly and then tries to perform nil.template.


Related issues

Related to Foreman - Bug #14521: TFTP orchestration fails for OS with iPXE w/o PXELinux associatedClosed2016-04-07
Is duplicate of Foreman - Bug #659: libvirt closes the connection too earlyDuplicate2011-02-08

Associated revisions

Revision cb624bf0 (diff)
Added by Ohad Levy over 8 years ago

fixes #612 - Print an error message when can not find a PXELinux template to render

History

#1 Updated by Ohad Levy over 8 years ago

I'm not sure i follow.. if you define the template in any of these places it should work:

1. os default template (in the os edit page)
2. in the template itself (by selecting the environment, hostgroup or both).

selecting which os's are valid per template does not mean they are rendered by default (as you might have a combination many templates that support certain oss).

#2 Updated by Ohad Levy over 8 years ago

pxe template might be missing, therefore we need to print the correct error message.

#3 Updated by Ohad Levy over 8 years ago

  • Category set to Host creation
  • Assignee set to Ohad Levy
  • Target version set to 0.2

#4 Updated by Ohad Levy over 8 years ago

  • Status changed from New to Ready For Testing
  • % Done changed from 0 to 100

#5 Updated by Ohad Levy over 8 years ago

  • Status changed from Ready For Testing to Closed

#6 Updated by Lukas Zapletal over 3 years ago

  • Related to Bug #14521: TFTP orchestration fails for OS with iPXE w/o PXELinux associated added

Also available in: Atom PDF