Project

General

Profile

Bug #6127

user shouldn't be allowed to update the content-host limit to -1 for selected host-colection

Added by Walden Raines almost 8 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
Web UI
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1105175
Description of problem:

Created a host-collection whose value was set to '10' for content-host limit. Later, I updated the limit with "-1", as soon as I type "-1", the text box closes and points to "unlimited" checkbox.

So -1 shouldn't be allowed for content host limit.

Version-Release number of selected component (if applicable):
sat6 beta snap8 (Satellite-6.0.3-RHEL-6-20140604.0)

How reproducible:
always

Steps to Reproduce:
1. create host collection with limit 10
2. update the limit with -1
3.

Actual results:
on updating the limit with -1, ticks the checkbox to unlimited

Expected results:
user shouldn't be allowed to set limit to -1

Additional info:
A related bz #848564


Related issues

Is duplicate of Katello - Bug #6078: -1 should not be used to represent "unlimited" for activation keys and host collectionsClosed2014-06-05

History

#1 Updated by Walden Raines almost 8 years ago

  • Status changed from New to Duplicate
  • Triaged set to No

Duplicate of #6078

#2 Updated by Walden Raines almost 8 years ago

  • Is duplicate of Bug #6078: -1 should not be used to represent "unlimited" for activation keys and host collections added

#3 Updated by Eric Helms almost 8 years ago

  • Triaged changed from No to Yes

#4 Updated by Eric Helms over 7 years ago

  • Legacy Backlogs Release (now unused) set to 13

#5 Updated by Eric Helms about 7 years ago

  • Legacy Backlogs Release (now unused) deleted (13)

#6 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF