Project

General

Profile

Bug #6174

Environment selection box and '+ Additional info' link disappears from system's details page

Added by Walden Raines almost 5 years ago. Updated 11 months ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Web UI
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1020808
Description of problem:
Register a system via rhsm and use published CV name while passing the env name.

for ex:

subscription-manager register --username admin --password admin --org org-name
--env env-name/cv-pub-name --force

System should be registered successfully. Now when you navigate the system -->All -->system details page, you will see the "Environment Selection box" and "+ Additional information" link.

But when you navigate to some other tab like 'packages' or events and come back to details tab, the environment selection box and "+ Additional info" link disappears

Version-Release number of selected component (if applicable):
snap6 compose2 (MDP2)
katello-1.4.6-40.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. Create a product/repo and sync it
2. create a cv and select the product and publish it
3. Promote the cv to next env
4. Register the system via rhsm and pass published name along ith env name ( as suggested above)
5. Go to Systems --All -> select registered systems --> details
6. Navigate to 'Package' or 'Events' tabs
7. Again select 'details' tab

Actual results:
Environment selection box and '+ Additional info' link disappears from system's details page

Expected results:
should be there

Additional info:

Associated revisions

Revision 4b4ebe36 (diff)
Added by Walden Raines almost 5 years ago

Fixes #6174/BZ 1020808 - ensure host advanced info link is displayed.

The problem was that the event 'contentHost.loaded' only fired upon
the first visit to this page. Using the $promise instead results
in the advanced info link being displayed each time.

Revision e5543cd8
Added by Walden Raines almost 5 years ago

Merge pull request #4253 from waldenraines/6174

Fixes #6174/BZ 1020808 - ensure host advanced info link is displayed.

Revision 6cf41a9f (diff)
Added by Walden Raines almost 5 years ago

Fixes #6174/BZ 1020808 - ensure host advanced info link is displayed.

The problem was that the event 'contentHost.loaded' only fired upon
the first visit to this page. Using the $promise instead results
in the advanced info link being displayed each time.

Revision 384fc2a1
Added by Walden Raines almost 5 years ago

Merge pull request #4253 from waldenraines/6174

Fixes #6174/BZ 1020808 - ensure host advanced info link is displayed.

History

#1 Updated by Walden Raines almost 5 years ago

  • Status changed from New to Ready For Testing
  • Triaged set to No

#2 Updated by Eric Helms almost 5 years ago

  • Target version set to 45
  • Difficulty set to trivial
  • Triaged changed from No to Yes

#3 Updated by Walden Raines almost 5 years ago

  • Difficulty changed from trivial to easy

Only trivial after knowing what the problem was, finding it wasn't trivial.

#4 Updated by Walden Raines almost 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Applied in changeset katello|commit:6cf41a9f2cd16065027a96d12508def0fc27b8e5.

#5 Updated by Eric Helms almost 5 years ago

  • Legacy Backlogs Release (now unused) set to 13

Also available in: Atom PDF