Project

General

Profile

Bug #6196

some hammer repo commands dont take product id or information

Added by Partha Aji over 5 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Hammer
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

$ hammer repository synchronize --help
Usage:
hammer repository synchronize [OPTIONS]

Options:
--async Do not wait for the task
--id ID repository ID
--name NAME Name to search by
--organization ORGANIZATION_NAME
--organization-id ORGANIZATION_ID
--organization-label ORGANIZATION_LABEL
-h, --help print help

But
$ hammer repository synchronize --name=<my-repo-name> --organization-id=1
fails with
Could not synchronize the repository:
Error: repository found more than once

It that v2/repositories index call doesnot take a "name" attribute. Due to which the hammer call to retrieve repo info from repo name returns all repositories in that organization.

[ INFO 2014-06-11 23:57:05 API] GET /katello/api/repositories
[DEBUG 2014-06-11 23:57:05 API] Params: {
"name" => <my-repo-name>,
"organization_id" => "1"
}
[DEBUG 2014-06-11 23:57:05 API] Headers: {
:params => {
"name" => <my-repo-name>,
"organization_id" => "1"
}
}
[DEBUG 2014-06-11 23:57:06 API] Response {
"total" => 4,
"subtotal" => 4,
.....
<returns all repos in org 1>
}


Related issues

Is duplicate of Katello - Bug #6203: some hammer repo commands dont take product id or informationClosed2014-06-12

History

#1 Updated by Partha Aji over 5 years ago

  • Bugzilla link set to https://bugzilla.redhat.com/show_bug.cgi?id=1108849

#2 Updated by Eric Helms over 5 years ago

  • Category set to Hammer
  • Difficulty set to easy
  • Triaged changed from No to Yes

#3 Updated by Adam Price over 5 years ago

  • Bugzilla link changed from https://bugzilla.redhat.com/show_bug.cgi?id=1108849 to https://bugzilla.redhat.com/show_bug.cgi?id=1108905

#4 Updated by Adam Price over 5 years ago

  • Subject changed from hammer repo synchronize does not work with repo name or pulp id to some hammer repo commands dont take product id or information

#5 Updated by Eric Helms almost 4 years ago

  • Legacy Backlogs Release (now unused) set to 86

#6 Updated by Eric Helms over 3 years ago

  • Status changed from New to Duplicate
  • Legacy Backlogs Release (now unused) changed from 86 to 114

#7 Updated by Eric Helms over 3 years ago

  • Is duplicate of Bug #6203: some hammer repo commands dont take product id or information added

Also available in: Atom PDF