Project

General

Profile

Bug #6211

pulp_auth under hammer ping cmd throwing undefined method error

Added by Partha Aji almost 5 years ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Installer
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1102521
Description of problem:
Installed new sat6 snap7 compose2 (Satellite/Satellite-6.0.3-RHEL-6-20140528.4)
After installation, I got error reported in bz:#1099933.

But when I checked the status with hammer ping command, found pulp-auth is throwing undefined method error:

[root@dhcp201-185 ~]# hammer ping
candlepin:
Status: ok
Server Response: Duration: 96ms
candlepin_auth:
Status: ok
Server Response: Duration: 32ms
pulp:
Status: ok
Server Response: Duration: 268ms
pulp_auth:
Status: FAIL
Server Response: Message: undefined method `resources' for nil:NilClass
elasticsearch:
Status: ok
Server Response: Duration: 88ms
katello_jobs:
Status: ok
Server Response: Duration: 30ms

Version-Release number of selected component (if applicable):
sat6 snap7 compose2 (Satellite/Satellite-6.0.3-RHEL-6-20140528.4)

How reproducible:
always

Steps to Reproduce:
1. install new build as pointed above
2. run hammer ping cmd after katello-installer
3.

Actual results:
pulp_auth:
Status: FAIL
Server Response: Message: undefined method `resources' for nil:NilClass

Expected results:
Status for All services should be 'ok'

Additional info:


Related issues

Has duplicate Katello - Bug #5840: Getting a pulp_auth error from the API ping actionDuplicate2014-05-20

Associated revisions

Revision 4e31fda9 (diff)
Added by David Davis almost 5 years ago

Fixes #6211,BZ1102521 - Requiring a user to ping pulp_auth

It looks like the code didn't properly set User.current so Katello.pulp_server
was nil. This code checks for a user in the controller. Also, it handles the
case of no user by skipping the pulp_auth check which needs remote_id from a
user.

Revision 9510426b
Added by David Davis almost 5 years ago

Merge pull request #4265 from daviddavis/temp/20140613091921

Fixes #6211,BZ1102521 - Use hidden user's remote id to ping pulp_auth

History

#1 Updated by David Davis almost 5 years ago

  • Has duplicate Bug #5840: Getting a pulp_auth error from the API ping action added

#2 Updated by David Davis almost 5 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Applied in changeset katello|commit:4e31fda91c136d2754bb8f5256507ae348d49576.

#3 Updated by Eric Helms almost 5 years ago

  • Target version set to 48
  • Triaged set to Yes

#4 Updated by Eric Helms over 4 years ago

  • Legacy Backlogs Release (now unused) set to 13

Also available in: Atom PDF