Project

General

Profile

Bug #6290

Association between katello's content-host and Foreman's host doesn't work

Added by Brad Buckingham about 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1111078
Description of problem:
I provisioned a host via foreman and auto register it with activation-key. The host was populated under content-host after auto registration with activation key. But Looks like "provisioning details" tab doesn't show any details.

it shows this msg:

"No provisioning details are available for this content host."

Version-Release number of selected component (if applicable):
sat6 beta snap10 (Satellite-6.0.3-RHEL-6-20140618.0)

How reproducible:
always

Steps to Reproduce:
1. Provision a host via foreman
2. Register it via rhsm to see under content-host

Actual results:
"Provisioning Details" tab doesn't show any info.

Expected results:
"Provisioning Details" tab should show info like: name, os, hostgroup and status.

Additional info:
Looks like its a regression as details were available during snap8

Associated revisions

Revision a3002822 (diff)
Added by Brad Buckingham about 5 years ago

fixes #6290 / BZ 1111078 - fix host <-> content host association during registration

This commit fixes the association of the host to content host that is
performed during registration. The code previously utilized the organization
instance variable that was obtained by the before_filters; however,
those filters are no longer used.

Revision bfcdbee2
Added by Brad Buckingham about 5 years ago

Merge pull request #4305 from bbuckingham/issue-6290

fixes #6290 / BZ 1111078 - fix host <-> content host association during registration

History

#1 Updated by Brad Buckingham about 5 years ago

  • Assignee set to Brad Buckingham
  • Target version set to 48
  • Legacy Backlogs Release (now unused) set to 13
  • Triaged set to Yes

#2 Updated by Brad Buckingham about 5 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Applied in changeset katello|commit:a3002822ff9a5397dc22a0ef3234d5f116376b2f.

Also available in: Atom PDF