Project

General

Profile

Feature #631

Allow template rendering without a specific host

Added by Justin Sherrill over 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
Category:
Unattended installations
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

As a user, I should be able to render a template with some default set of options. I shouldn't have to create a host just to render a template in a roundabout way.

Ohad brought up the idea of a hostgroup having default attributes for host creation, we could use that to render the template.


Related issues

Precedes Foreman - Feature #632: Support building PXE Menus on smart proxiesClosed2011-01-292011-01-29

Associated revisions

Revision e5d3f34e (diff)
Added by Ohad Levy over 8 years ago

Fixes #631 - Adds the ability to set default values for hostgroups, which
are automatically applied when creating a new host (and selecting that
host group), and allows for templates to be rendered with those default
hostgroup values

History

#1 Updated by Justin Sherrill over 8 years ago

Arg, this should be a feature as well, not a bug, but i am unable to change it.

#2 Updated by Ohad Levy over 8 years ago

  • Tracker changed from Bug to Feature

#3 Updated by Ohad Levy over 8 years ago

  • Status changed from New to Ready For Testing
  • % Done changed from 0 to 100

#4 Updated by Ohad Levy about 8 years ago

  • Status changed from Ready For Testing to Closed
  • Target version set to 0.2

Also available in: Atom PDF