Project

General

Profile

Bug #6403

power API returns error if using a hostgroup_id search filter

Added by Martin Matuška about 5 years ago. Updated over 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
API
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

If using a hostgroup_id search filter for the "Host/Managed" resource the power api returns an error:
"error": {"message":"undefined method `search_for' for #<Class:0x00000005f1a810>"}

I am attaching the backtrace.

backtrace.txt backtrace.txt 11.7 KB Backtrace Martin Matuška, 06/26/2014 10:19 AM

Related issues

Is duplicate of Foreman - Bug #8812: Pass model type in API base controllerClosed2014-12-30
Blocks Foreman - Tracker #4552: New permissions/authorization system issuesNew

History

#1 Updated by Dominic Cleal about 5 years ago

  • Blocks Tracker #4552: New permissions/authorization system issues added

#2 Updated by Dominic Cleal over 4 years ago

  • Is duplicate of Bug #8812: Pass model type in API base controller added

#3 Updated by Dominic Cleal over 4 years ago

  • Status changed from New to Duplicate

Thanks for the report Martin. Since we've got a PR under #8812 right now, I'll close this ticket and we'll fix it there.

Also available in: Atom PDF