Project

General

Profile

Bug #6411

Hammer: production.log filled up with garbage data when we upload contents to selected repo

Added by dustin tsang over 6 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Difficulty:
medium
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Created attachment 910661 [details]
Logs from production.log that contains garbage data, Not sure if its expected, but I don't think log file should include such data

Description of problem:
I was trying to upload contents to selected repo via hammer. Contents are uploaded successfully, however while uploading, the production.log filled up with some garbage data.

Processing by Katello::Api::V2::ContentUploadsController#create as application/json;version=2
Parameters: {"api_version"=>"v2", "repository_id"=>"17", "content_upload"=>{}}
Expire fragment views/tabs_and_title_records-1 (0.3ms)
Authorized user admin(Admin User)
Completed 200 OK in 171ms (Views: 0.7ms | ActiveRecord: 26.0ms)
Processing by Apipie::ApipiesController#apipie_checksum as JSON
Parameters: {"apipy"=>{}}
Rendered /opt/rh/ruby193/root/usr/share/gems/gems/apipie-rails-0.1.2/app/views/apipie/apipies/apipie_checksum.json.erb (0.2ms)
Completed 200 OK in 4ms (Views: 3.5ms | ActiveRecord: 0.0ms)
Processing by Katello::Api::V2::ContentUploadsController#update as application/json;version=2
Parameters: {"offset"=>"0", "content"=>"\u001F\x8B\b\u0000tdTR\u0000\u0003\xED=ks\xDB8\x92\xF3\x99\xBF\u0002\xE7\xA4J\xF6\x94-\xF3%R\xD2]\xA6Λ8\x89\xEB2v\xCANfkk*\xE5\u0005I\xD0\xE6\x86\"u$\u0015Ǘ\xF2\xFD\xF6\xEBƃ\")J\xB2c\x8D\x92Kػ\u0013K \xD0\xDD\xE8\a\u001A@\x83\xD0t6\x9D\xB2\"\xA6^~\x90ͼ\xDB\u0003\xBDo\xF4\xF5\xC3_6\n\xBA\xAE\xBB\x83\u0001\xE1\u007F\u001D\xF1W7m\xF1W\u00021L\xD3\u001C\xE8\x8Ei86э\x81=\xD0\u007F!\x83Ͳ\xD1\u000E\xB3\xBC\xA0\u0019\xB0B\xA7,I\xD8\xED\xD2zP-\fW\xE0\x91\xFD(\xFF\xFE?\x81i\xAB\xFE\x9F\xBF>:}u\xFC\xE6\xEC\xD5Fh\x80<\u001C\xDB^\xAE\xFF\x81\xD3Կ\xE38\xD6/D\xDF\b\xF55\xF0\x93\xEB\xDF\xD4\r\xEB\xC0\xD0\u000F\xF4!9 \u007F\xB0,\x8F҄p#д\x8B\xD9dB\xB3۱\xA6\x9D\xB3\x98ќ\u0011\x9A\x90\xD94\xA0\u0005\v\xC8'Y7\rIq\u001D\xE5}\xF2:\xBA\xBA\x8E\xE1\xBF\"'Q\xE2dz\x80\x913\x90\xE9\xC5\xFB\x8Bch\u0017\x90+\x96\xB0\x8C\xC6Z>͢\xE4\x8A\xF8\x801\xC1\u000FA\x9A0\xE2ݒt\x96\x91\x9B4\tX\u0016\xCEb⧓\xC9,\x89\x8A[2a\u0013\u000Fh\xFD\x9B\xA6\xBDd\xB4\x98e,\u001Fk\as\xD49\u0018p\x9A\u0015Pt\u0014\xC7\xE9\r\xF9'\x9A\xF1\u0015\x9B\xE4\x97S\xEA\u007F\xA4W\xEC\x9F$\u0005^\xB3(`}\xAC\u0014 '\x93\xEBt\xC2HH\xFDB\x95e\u0011\x91\xF5\xFB@(\xFA,\xA8\xBC\x89\x92\x

Version-Release number of selected component (if applicable):
sat6 beta snap10

How reproducible:
always

Steps to Reproduce:
hammer repository upload-content --id 17 --organization-id 1 --path /var/tmp/puppetlabs-ruby-0.1.0.tar.gz
Successfully uploaded file 'puppetlabs-ruby-0.1.0.tar.gz'.

check production.log

Actual results:

Expected results:
production.log should not be filled up with above garbage data.

Additional info:

Associated revisions

Revision 5fea2be7 (diff)
Added by dustin tsang over 6 years ago

Fixes #6411 - filter content param in CU BZ1111484

The content param in the content_uploads action is causing
the log to fill up with garbage since content is binary. This
filters the log so that the content_uploads the content param is
filtered.

Revision acc444b7
Added by dustin tsang over 6 years ago

Merge pull request #4364 from dustint-rh/filter_log_content_using_foreman_katello_plugin

Fixes #6411 - filter params by path BZ1111484

History

#1 Updated by dustin tsang over 6 years ago

  • Subject changed from https://bugzilla.redhat.com/show_bug.cgi?id=1111484 to Hammer: production.log filled up with garbage data when we upload contents to selected repo

#2 Updated by dustin tsang over 6 years ago

  • Status changed from New to Assigned

#3 Updated by Eric Helms over 6 years ago

  • Triaged changed from No to Yes

#4 Updated by Eric Helms over 6 years ago

  • Target version changed from 48 to 49

#5 Updated by The Foreman Bot over 6 years ago

  • Status changed from Assigned to Ready For Testing

#6 Updated by The Foreman Bot over 6 years ago

  • Target version deleted (49)

#7 Updated by The Foreman Bot over 6 years ago

  • Pull request https://github.com/Katello/katello/pull/4364 added

#8 Updated by Dominic Cleal over 6 years ago

  • Target version set to 49

#9 Updated by The Foreman Bot over 6 years ago

  • Pull request https://github.com/Katello/katello/pull/4357 added
  • Pull request deleted (https://github.com/Katello/katello/pull/4364)

#10 Updated by The Foreman Bot over 6 years ago

  • Pull request https://github.com/Katello/katello/pull/4364 added
  • Pull request deleted (https://github.com/Katello/katello/pull/4357)

#11 Updated by dustin tsang over 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#12 Updated by Eric Helms about 6 years ago

  • Legacy Backlogs Release (now unused) set to 13

Also available in: Atom PDF