Project

General

Profile

Bug #6470

Hostgroup selection box does not honor create_hosts filter

Added by Martin Matuška about 5 years ago. Updated about 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Authorization
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

When creating a new host, the hostgroup selection box shows all host groups (belonging to a organization) no matter what limitations are defined in the Hosts/Managed create_hostss filter.


Related issues

Is duplicate of Foreman - Feature #4477: Improve permissions on resources in host creation/editing formClosed2014-02-27

History

#1 Updated by Dominic Cleal about 5 years ago

  • Is duplicate of Feature #4477: Improve permissions on resources in host creation/editing form added

#2 Updated by Dominic Cleal about 5 years ago

  • Status changed from New to Duplicate

I'm going to tentatively mark this as a dupe of #4477, as this issue is prevalent across the whole host creation/edit form (e.g. with domains). The form wouldn't work well today if we restricted the related resources that users could see, as it would break on edit.

You raise an interesting point about the create_hosts permission - I don't think the filter would be applicable at all here, only for permissions that dealt with existing objects (i.e. view_hosts, power etc.) We'd likely only show host groups that match "view_hostgroups" if we did it.

#3 Updated by Neil Miao about 5 years ago

"We'd likely only show host groups that match "view_hostgroups" if we did it."

I guess this hasn't done yet :-)

In 1.5.1-2 new/edit host form still shows all host groups when view_hostgroups filter is set.

#4 Updated by Dominic Cleal about 5 years ago

Correct, please watch #4477.

Also available in: Atom PDF