Project

General

Profile

Bug #6494

roles API shall access foreman roles (not katello roles)

Added by Tomáš Strachota over 6 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Category:
API
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1102816
Description of problem:
It looks I'm accessing other roles when using roles API than the roles displayed in Sat6 WebUI.

Version-Release number of selected component (if applicable):
Satellite-6.0.3-RHEL-6-20140523.0-Satellite-x86_64

How reproducible:
always

Steps to Reproduce:
1.
$ curl -s -H "Content-Type:application/json" -H "Accept:application/json,version=2" -k -u admin:changeme -d'{"role":{"name":"new_role"}}' -X POST http://localhost/katello/api/roles {"created_at":"2014-05-29T15:29:37Z","updated_at":"2014-05-29T15:29:37Z","id":6,"name":"new_role","locked":false,"description":null}

Actual results:
But I do not see 'new_role' on https://<sat6_fqdn>/roles
Role with id = 6 is: 'View hosts'

Expected results:
roles API access the same roles as displayed on WebUI


Related issues

Is duplicate of Katello - Bug #5979: remove katello roles and permissions routes and apipieDuplicate2014-05-28

History

#1 Updated by Tomáš Strachota over 6 years ago

  • Status changed from New to Ready For Testing

#2 Updated by Tomáš Strachota over 6 years ago

  • Is duplicate of Bug #5979: remove katello roles and permissions routes and apipie added

#3 Updated by Tomáš Strachota over 6 years ago

  • Status changed from Ready For Testing to Closed

It's a duplicate of #5979. I'm closing this one.

#4 Updated by Eric Helms over 6 years ago

  • Triaged changed from No to Yes

#5 Updated by Eric Helms over 6 years ago

  • Target version set to 48

#6 Updated by Eric Helms about 6 years ago

  • Legacy Backlogs Release (now unused) set to 13

Also available in: Atom PDF