Project

General

Profile

Bug #6533

rest-client 1.7.0 dropped Ruby 1.8 support

Added by Dominic Cleal over 4 years ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Category:
Packaging
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

rest-client 1.7.0 has dropped Ruby 1.8 support, it needs pinning.

Gem::InstallError: rest-client requires Ruby version >= 1.9.2.


Related issues

Related to Foreman - Tracker #4656: Drop Ruby 1.8 supportClosed

Associated revisions

Revision 5dd7da2c (diff)
Added by Daniel Lobato Garcia over 4 years ago

Fixes #6533 - rest-client 1.7.0 dropped Ruby 1.8 support

Revision 89a8a641 (diff)
Added by Daniel Lobato Garcia over 4 years ago

Fixes #6533 - rest-client 1.7.0 dropped Ruby 1.8 support

(cherry picked from commit 5dd7da2cb7f31839019c40e9bb6a01ea67a8db0c)

History

#1 Updated by Dominic Cleal over 4 years ago

#2 Updated by Daniel Lobato Garcia over 4 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

#3 Updated by Bryan Kearney over 4 years ago

  • Bugzilla link set to 1117840

#4 Updated by Felix Barbeira over 4 years ago

The "1.5-stable" branch it's also affected. It looks like your commit it's only applied on "develop" branch. Maybe a cherry commit could be good.

#5 Updated by Dominic Cleal over 4 years ago

Yep, it'll be cherry picked soon when we start prepping for 1.5.2. Thanks!

Also available in: Atom PDF