Project

General

Profile

Feature #6605

[RFE] Satellite 6: Using activation key to register system - see the username under 'Registered by' column

Added by Christine Fouant over 6 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Category:
Web UI
Target version:
Difficulty:
medium
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1020402
++ This bug was initially created as a clone of Bug #805435 ++

Description of problem:
After registering a system using an activation key, we are not able to see the username under 'Registered By' colum on the Recently Registered systems page (i.e https://satellite.example.com/rhn/systems/Registered.do )

Version-Release number of selected component (if applicable):
RHN Satellite v5.4.1

How reproducible:
Always

Steps to Reproduce:
1. Register a system using an activation key
3. What is the nature and description of the request?
System registered using an username/password has the respective username under Registered By column.

But, after registering a system using an activation key, not able to see the username under 'Registered By' colum on the Recently Registered systems page
(i.e https://satellite.example.com/rhn/systems/Registered.do )

4. Why does the customer need this? (List the business requirements here)
It is a basic business requirement that there be individual accountability for the use of entitlements that cost the company money.

5. How would the customer like to achieve this? (List the functional requirements here)
As per the customer, RFE should cover the following functionality:
--Satellite should behave the same way as RHN with respect to the "Registered by" field in the context of an activation key.
--Both the GUI and the API should permit setting/changing the "Registered by" field.

6. For each functional requirement listed in question 5, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.
For system registered using an activation key, the user who had created the activation key should be displayed under Registered By column.

7. Is there already an existing RFE upstream or in Red Hat bugzilla?
No.

8. Does the customer have any specific timeline dependencies?
This will soon become an actual operational issue for them as they begin moving from RHN to Satellite. So they need it implemented as soon as possible.

9. Is the sales team involved in this request and do they have any additional input?

10. List any affected packages or components.
RHN Satellite

11. Would the customer be able to assist in testing this functionality if implemented?
Yes.

--- Additional comment from prajakta on 2013-08-30 02:48:01 EDT ---

Hello

Any further updates on this would be helpful to set customer expectations.

Thank you.

--- Additional comment from Clifford Perry on 2013-10-11 09:57:04 EDT ---

(In reply to prajakta from comment #8)

Hello

Any further updates on this would be helpful to set customer expectations.

Thank you.

This was not correctly flagged/tracked. I've moved it to sat-ff for myself and Xixi to review in our weekly RFE calls.

Cliff

--- Additional comment from Clifford Perry on 2013-10-17 11:19:18 EDT ---

So agree, within Sat 5.6 code, we still shwo Unknown with systems registered by activation-keys.

So we could add the activation key maybe (vs username of person who created the key, since an Admin user may of created key for usage by someone else in their Org).

Cliff

Associated revisions

Revision 1f66dcd3 (diff)
Added by Christine Fouant about 6 years ago

fixes #6605 - Adds registered by to content host, BZ 1020402

Revision 0fc6016a
Added by Walden Raines about 6 years ago

Merge pull request #4542 from cfouant/reg-by

fixes #6605 - Adds registered by to content host, BZ 1020402

History

#1 Updated by Eric Helms about 6 years ago

  • Tracker changed from Bug to Feature
  • Target version set to 54
  • Difficulty set to medium
  • Triaged changed from No to Yes

#2 Updated by The Foreman Bot about 6 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/4542 added
  • Pull request deleted ()

#3 Updated by Eric Helms about 6 years ago

  • Target version changed from 54 to 55

#4 Updated by Christine Fouant about 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Eric Helms about 6 years ago

  • Legacy Backlogs Release (now unused) set to 13

Also available in: Atom PDF