Project

General

Profile

Bug #665

smart-proxy fails to start with old Sinatra version

Added by Jochen Schalanda almost 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Low
Category:
-
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

On systems with an old version of Sinatra installed (<=1.0.a), smart-proxy fails to start with the following message:

./bin/../lib/sinatra-patch.rb:26:in `run!': undefined local variable or method `bind' for SmartProxy:Class (NameError)
        from bin/smart-proxy:63

On systems with a Sinatra version >=1.0, everything is working fine.

0001-Fixes-bug-665-Set-option-bind-or-host-depending-on-S.patch 0001-Fixes-bug-665-Set-option-bind-or-host-depending-on-S.patch 869 Bytes Patch for making smart-proxy work with Sinatra 1.0.a. Jochen Schalanda, 02/13/2011 11:03 AM

Associated revisions

Revision 52432e58 (diff)
Added by Jochen Schalanda over 9 years ago

Fixes #665 - Set option 'bind' or 'host' depending on Sinatra version.

History

#2 Updated by Ohad Levy over 9 years ago

  • Assignee set to Jochen Schalanda
  • Target version set to 0.1

#3 Updated by Jochen Schalanda over 9 years ago

  • Status changed from New to Ready For Testing
  • % Done changed from 0 to 100

#4 Updated by Ohad Levy over 9 years ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF