Project

General

Profile

Bug #6652

"Run Auto-Attach" does not work and can not disable "Auto Attach"

Added by Christine Fouant almost 6 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Category:
Web UI
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1113879
Description of problem:

Go to Hosts -> Content Hosts -> Select system profile

Issue 1.

- Go to Details
- Subscriptions section or Subscriptions tab
- Click on the edit option for "Auto-Attach "
- Uncheck the box and click on Save
- Still Auto-Attach is set as "Yes"

Issue 2:

- Go to Subscriptions tab
- Click on "Run Auto-Attach"

Auto Attach does not attach any subscription.

Issue 3:

- Go to Subscriptions
- Click on Edit option for "Service Level"
- Select service level as "Self-Support"
- Click on "Save"
- Service level is blank/null

Version-Release number of selected component (if applicable):
Satellite v 6.0.3

How reproducible:
Always

Steps to Reproduce:
As described above.


Related issues

Has duplicate Katello - Bug #5545: content host UI - changes to Auto-Attach are not persistedDuplicate2014-05-01

Associated revisions

Revision 367752a7 (diff)
Added by Christine Fouant almost 6 years ago

fixes #6652, #6578, #6738 - Enables setting auto-attach and triggers auto-attach and shows service level, BZ 1113879, BZ 1019227, BZ 999122

Revision 8c6c44b6
Added by Thomas McKay almost 6 years ago

Merge pull request #4444 from cfouant/auto-attach

fixes #6652, #6578, #6738 - Enables setting auto-attach and triggers auto-attach and shows service level, BZ 1113879, BZ 1019227, BZ 999122

History

#1 Updated by The Foreman Bot almost 6 years ago

  • Status changed from New to Ready For Testing
  • Target version set to 49
  • Pull request https://github.com/Katello/katello/pull/4444 added
  • Pull request deleted ()

#2 Updated by Eric Helms almost 6 years ago

  • Difficulty set to easy
  • Triaged changed from No to Yes

#3 Updated by Eric Helms almost 6 years ago

  • Is duplicate of Bug #5545: content host UI - changes to Auto-Attach are not persisted added

#4 Updated by Eric Helms almost 6 years ago

  • Is duplicate of deleted (Bug #5545: content host UI - changes to Auto-Attach are not persisted)

#5 Updated by Eric Helms almost 6 years ago

  • Has duplicate Bug #5545: content host UI - changes to Auto-Attach are not persisted added

#6 Updated by Eric Helms almost 6 years ago

  • Target version changed from 49 to 54

#7 Updated by Christine Fouant almost 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#8 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 13

Also available in: Atom PDF