Project

General

Profile

Bug #6658

creating compute resource with name more than 245 chars fails

Added by Ori Rabin over 7 years ago. Updated over 7 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Database
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1120271
Description of problem:

Creating a compute resource name with 245 chars fails with the below error.

PGError: ERROR: value too long for type character varying(255) : INSERT INTO "compute_resources" ("attrs", "created_at", "description", "name", "password", "type", "updated_at", "url", "user", "uuid") VALUES ($1, $2, $3, $4, $5, $6, $7, $8, $9, $10) RETURNING "id"

I believe the actual limit is 255 chars and anything from 256 chars should fail.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:
compute resource name with 245 chars fails

Expected results:

compute resource name with upto 255 chars should be possible.
Additional info:


Related issues

Related to Foreman - Bug #6712: PGError when media name exceeds 255 charactersDuplicate2014-07-22
Related to Foreman - Bug #6636: Audit log field too small - PGError while creating OS with 255 characters in nameClosed2014-07-16
Related to Foreman - Bug #4153: Model validation errorDuplicate2014-01-21
Is duplicate of Foreman - Bug #6694: PGError: while creating OS with long (greater than 5 chars) minor/major version valuesClosed2014-07-20

History

#1 Updated by Ori Rabin over 7 years ago

  • Assignee set to Ori Rabin

#2 Updated by Ori Rabin over 7 years ago

  • Status changed from New to Assigned

#3 Updated by The Foreman Bot over 7 years ago

  • Status changed from Assigned to Ready For Testing
  • Target version set to 1.8.0
  • Pull request https://github.com/theforeman/foreman/pull/1595 added
  • Pull request deleted ()

#4 Updated by Dominic Cleal over 7 years ago

  • Category set to Database

#5 Updated by Dominic Cleal over 7 years ago

  • Related to Bug #6712: PGError when media name exceeds 255 characters added

#6 Updated by Dominic Cleal over 7 years ago

  • Related to Bug #6636: Audit log field too small - PGError while creating OS with 255 characters in name added

#7 Updated by Dominic Cleal over 7 years ago

  • Related to Bug #4153: Model validation error added

#9 Updated by Dominic Cleal over 7 years ago

  • Is duplicate of Bug #6694: PGError: while creating OS with long (greater than 5 chars) minor/major version values added

#10 Updated by Dominic Cleal over 7 years ago

  • Status changed from Ready For Testing to Duplicate
  • Target version deleted (1.8.0)
  • Bugzilla link deleted (1120271)

Also available in: Atom PDF