Project

General

Profile

Feature #6704

Smart Parameter Editing Auditing

Added by Ian Tewksbury over 7 years ago. Updated about 7 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Audit Log
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

It would be great to have audit messages whenever a smart parameter override is edited with:

  • who edited
  • what parameter was edited
  • what the matcher is
  • what the value is

If an existing parameter was edited it would be great if the old value was also listed.

Auditing if the default values are changed would be great as well.


Related issues

Is duplicate of Foreman - Bug #1902: Smart Parameters aren't audit loggedClosed2012-10-17

History

#1 Updated by Eric Helms about 7 years ago

  • Project changed from Katello to Foreman

#2 Updated by Dominic Cleal about 7 years ago

  • Is duplicate of Bug #1902: Smart Parameters aren't audit logged added

#3 Updated by Dominic Cleal about 7 years ago

  • Category set to Audit Log
  • Status changed from New to Duplicate

Thanks for the bug report. I believe this has been fixed in Foreman 1.5.0 via #1902.

Also available in: Atom PDF