Project

General

Profile

Bug #6711

bootdisk seems to only support static networking

Added by Dominic Cleal over 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1120762
Description of problem:

This is probably more wide spread than just bootdisk, but the following template:

https://github.com/theforeman/foreman/blob/develop/app/views/unattended/kickstart/iPXE.erb

seems to only support static networking.

<% static = @host.token.nil? ? '?static=yes' : '&static=yes' -%>

seems to indicate that static networking would be used in all cases. In my case I did not have a subnet defined so the request to the kickstart attempted to use static networking and failed with 'undefined method mask for nil'.

How reproducible:
Always

Steps to Reproduce:
1. Create a host and do not specify a subnet (because its not needed)
2. Attempt to provision a system with bootdisk

Actual results:
Will fail.

Expected results:
Removing the static information seems to make it work just fine.

Additional info:


Related issues

Blocked by Foreman - Feature #5458: Make setting static IP more user friendlyClosed2014-04-25

History

#1 Updated by Dominic Cleal over 4 years ago

  • Blocked by Feature #5458: Make setting static IP more user friendly added

#2 Updated by Dominic Cleal over 4 years ago

This is by design for the host-specific disk, but I guess less so for the generic disk. Once Foreman has a way to specify static/dynamic config per host then it'll be easier to fix this without introducing an additional type of disk, or breaking it for other users.

#3 Updated by Marek Hulán about 4 years ago

I think this works as expected, when I tried to generate host-specific image I got an Foreman exception that subnet is not specified, for generic image it seems to work just fine. The user experience is not ideal since they don't see nice error explaining why it does not work, but that's a different story. Dominic, could you please confirm? This is my first bootdisk bug :-) Maybe the output of this issue would be to improve documentation?

#4 Updated by Dominic Cleal about 4 years ago

  • Status changed from New to Resolved

#5458 indeed fixed this to my knowledge.

The error about missing subnet is by design, but improvements are definitely welcome - it's certainly a different issue to this.

#5 Updated by Bryan Kearney about 4 years ago

Dominic Cleal wrote:

#5458 indeed fixed this to my knowledge.

The error about missing subnet is by design, but improvements are definitely welcome - it's certainly a different issue to this.

was this opened?

#6 Updated by Dominic Cleal almost 4 years ago

Not as far as I can tell, feel free to file a PR or ticket.

Also available in: Atom PDF