Project

General

Profile

Actions

Feature #6785

closed

64 Bit Support

Added by Paul Calabro almost 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

Hi,

First off, thanks for providing such a useful plugin! I'm delighted this plugin has come to fruition! :)

Now to my actual issue. When I go to create a VM, which I expect to be of type x86_64, instead I receive this following error during provisioning:

"This kernel requires an x86-64 CPU, but only detected an i686 CPU."

It sounds like this guy is having the same issue as well: https://groups.google.com/forum/#!topic/foreman-users/HS8Yrr3UdIw

Cold you please add support for 64 bit?


Related issues 1 (0 open1 closed)

Blocked by Foreman - Bug #6670: Update fog to 1.23Closed07/17/2014Actions
Actions #1

Updated by George Lucan almost 10 years ago

Hello,

That is an issue with the fog classes that foreman-xen uses. I have submited a patch to fog and they merged it to github. The required change is here: https://github.com/georgyous/fog/commit/e80fcc69679b90d4b92e348a88b5c100cb49cf4b

Thank you

Actions #2

Updated by Paul Calabro almost 10 years ago

This resolved my issue! Thanks for the quick turnaround! :)

Actions #3

Updated by Anonymous almost 10 years ago

That commit should already be in fog 1.23

Actions #4

Updated by Anonymous almost 10 years ago

  • Blocked by Bug #6670: Update fog to 1.23 added
Actions #5

Updated by Anonymous almost 10 years ago

Paul, could you confirm that this bug is fixed with Foreman 1.6? 1.6 is using fog 1.23, so that fix should be in.

Actions #6

Updated by Paul Calabro almost 10 years ago

Sure, spinning up a test VM right now.

Actions #7

Updated by Paul Calabro almost 10 years ago

This can be closed. I tested on a fresh install and this worked fine.

Actions #8

Updated by Anonymous almost 10 years ago

  • Status changed from New to Closed

Thanks a lot, closing.

Actions

Also available in: Atom PDF