Project

General

Profile

Bug #6820

hammer repository-set enable: {} are not valid substitutions for /content/dist/rhel/server/6/$releasever/$basearch/kickstart (RuntimeError)

Added by Adam Price almost 6 years ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:
In Kanboard:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1116803
Description of problem:
Calling `hammer repository-set enable ...` produces error "{} are not valid substitutions for /content/dist/rhel/server/6/$releasever/$basearch/kickstart (RuntimeError)"

Version-Release number of selected component (if applicable):
Satellite-6.0.3-RHEL-7-20140702.0

How reproducible:
always

Steps to Reproduce:
1. # hammer product list --organization-id 3 | grep 5
5 | Red Hat Enterprise Linux Server | satellite-qa | 1 | not_synced
2. # hammer repository-set list --product-id 5 | grep 1952
1952 | kickstart | Red Hat Enterprise Linux 6 Server (Kickstart)
3. # hammer repository-set enable --product-id 5 --id 1952

Actual results:
  1. hammer repository-set enable --product-id 5 --id 1952
    Could not enable repository: {} are not valid substitutions for /content/dist/rhel/server/6/$releasever/$basearch/kickstart

Expected results:
Should work

Associated revisions

Revision 9164c519 (diff)
Added by Adam Price almost 6 years ago

refs #6820 - catching apipie-bindings' MissingArgumentsError

Revision ffe399c9 (diff)
Added by Adam Price almost 6 years ago

refs #6820 - bumping version to pull the newest apipie-bindings

Revision f3c47c75
Added by mbacovsky almost 6 years ago

Merge pull request #132 from komidore64/rmi6820-require-apidoc-params

refs #6820 - catching apipie-bindings' MissingArgumentsError

History

#1 Updated by The Foreman Bot almost 6 years ago

  • Status changed from New to Ready For Testing
  • Target version set to 54
  • Pull request https://github.com/theforeman/hammer-cli/pull/132 added
  • Pull request deleted ()

#2 Updated by Eric Helms almost 6 years ago

  • Triaged changed from No to Yes

#3 Updated by Eric Helms almost 6 years ago

  • Project changed from Katello to Hammer CLI
  • Category deleted (Hammer)
  • Target version deleted (54)

#4 Updated by The Foreman Bot almost 6 years ago

  • Target version set to 1.7.4

#5 Updated by Dmitri Dolguikh almost 6 years ago

  • Target version changed from 1.7.4 to 1.7.3

#6 Updated by Dominic Cleal almost 6 years ago

  • Target version changed from 1.7.3 to 1.7.2

#7 Updated by Bryan Kearney over 4 years ago

  • Status changed from Ready For Testing to New

downstream is still seeingthis

#8 Updated by Shira Maximov 7 months ago

  • Triaged set to No

I'm closing this issue since the BZ was closed and the PR was merged long time ago.

#9 Updated by Shira Maximov 7 months ago

  • Status changed from New to Resolved

Also available in: Atom PDF