Project

General

Profile

Bug #6880

katello/satellite kickstart default for rhel includes puppet in packages list, branding

Added by Stephen Benjamin over 5 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Hosts
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1102864
Description of problem:
the "Katello kickstart default for RHEL" template includes puppet in the packages list

Version-Release number of selected component (if applicable):
foreman-1.6.0.13-1.el6sat.noarch
foreman-compute-1.6.0.13-1.el6sat.noarch
foreman-gce-1.6.0.13-1.el6sat.noarch
foreman-libvirt-1.6.0.13-1.el6sat.noarch
foreman-ovirt-1.6.0.13-1.el6sat.noarch
foreman-postgresql-1.6.0.13-1.el6sat.noarch
foreman-proxy-1.6.0.6-1.el6sat.noarch
foreman-vmware-1.6.0.13-1.el6sat.noarch
katello-1.5.0-25.el6sat.noarch
katello-ca-1.0-1.noarch
katello-certs-tools-1.5.5-1.el6sat.noarch
katello-installer-0.0.44-1.el6sat.noarch
pulp-katello-plugins-0.3-1.el6sat.noarch
ruby193-rubygem-foreman_bootdisk-2.0.6-1.1.el6sat.noarch
ruby193-rubygem-foreman_discovery-1.3.0-0.1.rc2.el6sat.noarch
ruby193-rubygem-foreman_hooks-0.3.5-2.el6sat.noarch
ruby193-rubygem-foreman-redhat_access-0.0.4-1.el6sat.noarch
ruby193-rubygem-foreman-tasks-0.5.7-2.el6sat.noarch
ruby193-rubygem-katello-1.5.0-51.el6sat.noarch
rubygem-hammer_cli_foreman-0.1.1-5.el6sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3-2.el6sat.noarch
rubygem-hammer_cli_katello-0.0.4-4.el6sat.noarch

How reproducible:
100%

Steps to Reproduce:
1. Open "katello kickstart default for rhel" provisioning template

Actual results:
%packages --ignoremissing
yum
dhclient
ntp
wget
@Core
puppet

Expected results:
%packages --ignoremissing
yum
dhclient
ntp
wget
@Core

Additional info:
puppet only becomes available after registration with an activation key, as it is not in the RHEL kickstart repo (it's part of rh-common").


Related issues

Related to Katello - Bug #7049: Puppet not being installed in kickstart katelloDuplicate

Associated revisions

Revision 6b648f8f (diff)
Added by Stephen Benjamin over 5 years ago

fixes #6880 - remove puppet from packages section

Revision 194ed43e
Added by Stephen Benjamin over 5 years ago

Merge pull request #4516 from stbenjam/6880

fixes #6880 - remove puppet from packages section

History

#1 Updated by The Foreman Bot over 5 years ago

  • Status changed from New to Ready For Testing
  • Target version set to 54
  • Pull request https://github.com/Katello/katello/pull/4516 added
  • Pull request deleted ()

#2 Updated by Eric Helms over 5 years ago

  • Triaged changed from No to Yes

#3 Updated by Anonymous over 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Partha Aji over 5 years ago

  • Assignee changed from Partha Aji to Stephen Benjamin

#5 Updated by Leah Fisher over 5 years ago

Due to this change, we are now not trying to install puppet at all, but are expecting puppet to be configured if puppet_enable is true. Don't we need a yum install puppet before we start configuring puppet?

#7 Updated by Stephen Benjamin over 5 years ago

Ah, I see, it's not in the other one:

https://github.com/Katello/katello/blob/master/app/views/foreman/unattended/kickstart-katello.erb

Can you file a separate issue please?

In reality, these templates are 90+% similar and should just be turned into one, no need to have separate templates for CentOS and RHEL.

#8 Updated by Eric Helms over 5 years ago

  • Related to Bug #7049: Puppet not being installed in kickstart katello added

#9 Updated by Eric Helms over 5 years ago

  • Legacy Backlogs Release (now unused) set to 13

Also available in: Atom PDF