Project

General

Profile

Bug #6886

User should not be allowed to create OS with same name and version

Added by Dominic Cleal over 5 years ago. Updated about 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Rails
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1120985
Description of problem:
I was trying to create OS with name RedHat and version 6.5. Later, I realized OS was already there with same name and version. I think UI should throw some error message that "OS Name with same version has already been taken"

I think we can't uniqueify OS just on the basis of name. As OS can be of same name but with diff versions.

Version-Release number of selected component (if applicable):
sat6 GA snap1

How reproducible:
always

Steps to Reproduce:
1. create a OS with name RedHat and major/minor version: 6/5
2. create another OS with same name and version.
3.

Actual results:
UI allows use to create OS with same name and version

Expected results:
UI should throw error if one OS already there with same name and version

Additional info:


Related issues

Is duplicate of Foreman - Bug #7743: Duplicate OSes can be createdClosed2014-09-29

History

#1 Updated by Dominic Cleal over 5 years ago

  • Category set to Rails

#2 Updated by Tomer Brisker about 5 years ago

  • Status changed from New to Assigned
  • Assignee set to Tomer Brisker

#3 Updated by The Foreman Bot about 5 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/1962 added
  • Pull request deleted ()

#4 Updated by Shlomi Zadok about 5 years ago

This is a duplicate of #7743
And there is a pending PR for this for a long time at https://github.com/theforeman/foreman/pull/1885

#5 Updated by Dominic Cleal about 5 years ago

  • Is duplicate of Bug #7743: Duplicate OSes can be created added

#6 Updated by Dominic Cleal about 5 years ago

  • Status changed from Ready For Testing to Duplicate
  • Assignee deleted (Tomer Brisker)

Also available in: Atom PDF