Project

General

Profile

Bug #6890

Puppet environment cannot be edited when name is only numeric

Added by Dominic Cleal about 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
Web Interface
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1126033
Description of problem:

Puppet-environment allows creation of names with numeric values, but fails to edit.

The UI states that "only alhanumeric and no spaces".

tail -f /var/log/foreman/production.log

Processing by EnvironmentsController#edit as */*
Parameters: {"id"=>"454981231"}
Rendered common/404.html.erb within layouts/application (1.9ms)
Rendered layouts/base.html.erb (2.2ms)
Completed 404 Not Found in 46ms (Views: 7.8ms | ActiveRecord: 3.9ms)

Version-Release number of selected component (if applicable):
Sat6-GA-snap3

How reproducible:
when using numeric values for puppet-environment.

Steps to Reproduce:
1.
2.
3.

Actual results:
Fails to edit an puppet-environment when it's a numeric value.

Expected results:
From the UI message it looks like only alphanumeric values are allowed.

Additional info:


Related issues

Related to Foreman - Bug #6914: puppet class with numeric name can neither be edited nor deleted.Closed2014-08-04
Related to Foreman - Feature #4386: implement gem friendly_id to simply find by id, name, label, etcClosed2014-02-19

History

#1 Updated by Dominic Cleal about 5 years ago

  • Category set to Web Interface

#2 Updated by Dominic Cleal about 5 years ago

  • Related to Bug #6914: puppet class with numeric name can neither be edited nor deleted. added

#3 Updated by Dominic Cleal almost 5 years ago

  • Related to Feature #4386: implement gem friendly_id to simply find by id, name, label, etc added

#4 Updated by Dominic Cleal almost 5 years ago

  • Status changed from New to Closed
  • Target version set to 1.7.2
  • Legacy Backlogs Release (now unused) set to 21

Fixed via #4386.

Also available in: Atom PDF