Project

General

Profile

Bug #6898

deleteing a host does not delete a content host, generates a FK constrain error

Added by Ohad Levy almost 8 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Hosts
Target version:
Difficulty:
easy
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

upon trying to delete a foreman host with content, the following is observed:

ERROR: update or delete on table "hosts" violates foreign key constraint "katello_systems_host_id" on table "katello_systems" DETAIL: Key (id)=(6) is still referenced from table "katello_systems".


Related issues

Related to Katello - Bug #6897: unable to view foreman hosts show pageDuplicate2014-08-03
Has duplicate Katello - Bug #7005: Unable to delete host tied back to activation keyClosed2014-08-09

History

#1 Updated by Eric Helms almost 8 years ago

  • Target version set to 54
  • Difficulty set to easy
  • Triaged changed from No to Yes

#2 Updated by Eric Helms almost 8 years ago

  • Related to Bug #6897: unable to view foreman hosts show page added

#3 Updated by Brad Buckingham almost 8 years ago

  • Status changed from New to Duplicate

This one appears to be a duplicate of http://projects.theforeman.org/issues/7005. If you see the issue persist, now that 7005 has been merged, please do let us know. Thanks!

#4 Updated by Brad Buckingham almost 8 years ago

  • Has duplicate Bug #7005: Unable to delete host tied back to activation key added

#5 Updated by Eric Helms almost 8 years ago

  • Legacy Backlogs Release (now unused) set to 13

#6 Updated by Eric Helms about 7 years ago

  • Legacy Backlogs Release (now unused) deleted (13)

#7 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF