Project

General

Profile

Bug #6926

New user with just anonymous role will get 403 Forbidden upon logon to / (redirected to /hosts)

Added by Jan Pazdziora almost 5 years ago. Updated almost 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

If new user is created with no roles (so I assume it just has anonymous), by default upon logon they get redirected to /hosts and they will see

Permission denied
You are not authorized to perform this action
Please request the required privileges from a foreman administrator

What's more, the HTTP status of this page is 403, which breaks tests.

I believe Foreman should not auto-redirect users to pages they are not able to see. The page /bookmarks works fine.


Related issues

Related to Foreman - Bug #6361: menu item "Hosts --> All hosts" is visible to normal user from anonymous role by defaultClosed2014-06-24
Is duplicate of Foreman - Bug #1632: On login with minimal permissions, user is always taken to host pageNew2012-05-18

History

#1 Updated by Dominic Cleal almost 5 years ago

  • Is duplicate of Bug #1632: On login with minimal permissions, user is always taken to host page added

#2 Updated by Dominic Cleal almost 5 years ago

  • Related to Bug #6361: menu item "Hosts --> All hosts" is visible to normal user from anonymous role by default added

#3 Updated by Dominic Cleal almost 5 years ago

  • Status changed from New to Duplicate

Thanks for the report, I think we have it covered under #1632. This happened the other day when the default view_hosts permission was removed from Anonymous.

Also available in: Atom PDF