Project

General

Profile

Actions

Bug #6927

closed

Capsule installer 'succeeds' very quickly (but fails with no error) if system is not registered.

Added by Ivan Necas almost 10 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Foreman Proxy Content
Target version:
Difficulty:
easy
Triaged:
Yes
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1104781
Description of problem:

When running a capsule install the install completed within just a few seconds with no error, but there was some information in the logs:

[ INFO 2014-06-04 11:23:46 main] /usr/share/katello-installer/modules/common/lib/puppet/parser/functions/validate_pulp.rb:21:in `function_validate_pulp'
[ INFO 2014-06-04 11:23:46 main] /usr/lib/ruby/site_ruby/1.8/puppet/parser/ast/function.rb:33:in `send'
[ INFO 2014-06-04 11:23:46 main] /usr/lib/ruby/site_ruby/1.8/puppet/parser/ast/function.rb:33:in `evaluate'
[ INFO 2014-06-04 11:23:46 main] /usr/lib/ruby/site_ruby/1.8/puppet/parser/ast.rb:73:in `safeevaluate'
[ INFO 2014-06-04 11:23:46 main] /usr/lib/ruby/site_ruby/1.8/puppet/parser/ast/astarray.rb:25:in `evaluate'
[ INFO 2014-06-04 11:23:46 main] /usr/lib/ruby/site_ruby/1.8/puppet/parser/ast/astarray.rb:20:in `each'
[ INFO 2014-06-04 11:23:46 main] /usr/lib/ruby/site_ruby/1.8/puppet/parser/ast/astarray.rb:20:in `evaluate'
[ INFO 2014-06-04 11:23:46 main] /usr/lib/ruby/site_ruby/1.8/puppet/parser/ast.rb:73:in `safeevaluate'
[ INFO 2014-06-04 11:23:46 main] /usr/lib/ruby/site_ruby/1.8/puppet/parser/ast/ifstatement.rb:25:in `evaluate'
[ INFO 2014-06-04 11:23:46 main] /usr/lib/ruby/site_ruby/1.8/puppet/parser/ast.rb:73:in `safeevaluate'
[ INFO 2014-06-04 11:23:46 main] /usr/lib/ruby/site_ruby/1.8/puppet/parser/ast/astarray.rb:25:in `evaluate'
[ INFO 2014-06-04 11:23:46 main] /usr/lib/ruby/site_ruby/1.8/puppet/parser/ast/astarray.rb:20:in `each'
[ INFO 2014-06-04 11:23:46 main] /usr/lib/ruby/site_ruby/1.8/puppet/parser/ast/astarray.rb:20:in `evaluate'
[ INFO 2014-06-04 11:23:46 main] /usr/lib/ruby/site_ruby/1.8/puppet/parser/ast.rb:73:in `safeevaluate'

looking at /usr/share/katello-installer/modules/common/lib/puppet/parser/functions/validate_pulp.rb:21:in `function_validate_pulp'

revealed:

raise Puppet::ParseError,
"The system has to be registered to a Katello instance before installing the node"

for some reason this exception did not trickle up to kafo.


Related issues 1 (0 open1 closed)

Related to Kafo - Bug #6978: Report validation messages to the end userClosedDominic Cleal08/07/2014Actions
Actions #1

Updated by Ivan Necas almost 10 years ago

  • Status changed from New to Assigned
  • Target version set to 54
  • Difficulty set to easy
Actions #2

Updated by The Foreman Bot almost 10 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/Katello/katello-installer/pull/96 added
  • Pull request deleted ()
Actions #3

Updated by Eric Helms almost 10 years ago

  • Triaged changed from No to Yes
Actions #4

Updated by Ivan Necas almost 10 years ago

  • Related to Bug #6978: Report validation messages to the end user added
Actions #5

Updated by Ivan Necas almost 10 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100
Actions #6

Updated by Eric Helms almost 10 years ago

  • Translation missing: en.field_release set to 13
Actions #7

Updated by Ivan Necas over 9 years ago

  • Status changed from Closed to Assigned
  • Target version changed from 54 to 59
  • Translation missing: en.field_release changed from 13 to 24
Actions #8

Updated by Eric Helms over 9 years ago

  • Status changed from Assigned to Closed
Actions #9

Updated by Eric Helms over 9 years ago

  • Translation missing: en.field_release changed from 24 to 14
Actions

Also available in: Atom PDF