Project

General

Profile

Bug #6956

foreman-proxy requires rubygem-rack => 1.1.0

Added by Leah Fisher over 6 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Packaging
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

When trying to start the foreman-proxy service, it would start and then crash with no errors. This was due to the having rubygem-rack-1.0.1-2.el6.noarch installed. Better error messages and a possible version requirement on the foreman proxy rpm would be helpful.


Related issues

Related to Smart Proxy - Refactor #4866: As a developer I'd like to break up smart-proxy into multiple componentsClosed2014-03-26

Associated revisions

Revision 165c257e (diff)
Added by Dominic Cleal over 6 years ago

fixes #6956 - rack 1.1 minimum required for Rack::Server#start

History

#1 Updated by Dominic Cleal over 6 years ago

  • Project changed from Foreman to Packaging
  • Legacy Backlogs Release (now unused) set to 10

Likely the same for debs too.

#2 Updated by Dominic Cleal over 6 years ago

  • Related to Refactor #4866: As a developer I'd like to break up smart-proxy into multiple components added

#3 Updated by Dominic Cleal over 6 years ago

  • Project changed from Packaging to Smart Proxy
  • Category set to Packaging
  • Assignee set to Dominic Cleal

#4 Updated by The Foreman Bot over 6 years ago

  • Status changed from New to Ready For Testing
  • Target version set to 1.7.5
  • Pull request https://github.com/theforeman/smart-proxy/pull/196 added
  • Pull request deleted ()

#5 Updated by Dominic Cleal over 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF