Project

General

Profile

Bug #6957

Package upload fails with larger rpms (30MB+) on 413 Request Entry Too Large

Added by Partha Aji about 6 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Hammer
Target version:
Difficulty:
medium
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1121950
Description of problem:
Package upload fails with larger rpms (30MB+) on 413 Request Entry Too Large

How reproducible:
Always

Steps to Reproduce:
1. hammer repository upload-package --id REPO_ID --path jre-7u45-linux-x64.rpm
2. fails with "413 Request Entry Too Large" error message in the hammer log

Expected results:
The package is uploaded successfully

Additional info:

Associated revisions

Revision 26bbb0cd (diff)
Added by David Davis about 6 years ago

Fixes #6957,BZ1121950 - Using small file upload chunks

Using smaller chunk sizes for file uploads. In production, we're getting 413
responses. It looks like the SSL negotiation (which is limited by
SSLRenegBufferSize) is hitting its limit. After some trial-and-error, the limit
seemed to be around 5-6 MB so I'm adding in some buffer and using 4 MB.

Revision b3ae848e
Added by David Davis about 6 years ago

Merge pull request #215 from daviddavis/temp/20140806093204

Fixes #6957,BZ1121950 - Using small file upload chunks

History

#1 Updated by The Foreman Bot about 6 years ago

  • Status changed from New to Ready For Testing
  • Target version set to 54
  • Pull request https://github.com/Katello/hammer-cli-katello/pull/215 added
  • Pull request deleted ()

#2 Updated by David Davis about 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Eric Helms about 6 years ago

  • Difficulty set to medium
  • Triaged changed from No to Yes

#4 Updated by Eric Helms about 6 years ago

  • Legacy Backlogs Release (now unused) set to 13

#5 Updated by Juan Pablo Lorier over 4 years ago

I'm having this problem uploading rpms. Are you planning on fixing this? TSM client bigger rpms are 124MB and 78 MB.
Regards

#6 Updated by Juan Pablo Lorier over 4 years ago

Sorry, I forgot to tell my problem is by the web UI, not hammer.
Regards

#7 Updated by David Davis over 4 years ago

Juan, mind opening a new redmine issue with what you're seeing? Make sure to attach the relevant portions of /var/foreman/production.log too. Thanks!

Also available in: Atom PDF