Project

General

Profile

Bug #7013

apipie-rails 0.2.3 is incompatible with 1.8.7

Added by Daniel Lobato Garcia over 4 years ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Category:
Packaging
Target version:
Difficulty:
trivial
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Discovered after repeated failed jobs on 1.8.7 - http://ci.theforeman.org/view/Core/job/test_develop/795/database=postgresql,ruby=1.8.7/console

Error in apipie-rails is trivial, apipie-rails requires pinning on Foreman until its solved.


Related issues

Related to Foreman - Tracker #4656: Drop Ruby 1.8 supportClosed

Associated revisions

Revision 33a90a9e (diff)
Added by Daniel Lobato Garcia over 4 years ago

Fixes #7013 - pin apipie-rails to < 0.2.3

0.2.3 was released with a Ruby 1.8.7 incompatible syntax method
definition

Revision c586ad99 (diff)
Added by Dominic Cleal over 4 years ago

refs #7013 - pin apipie-rails to < 0.2.3

Revision 028aa63a (diff)
Added by Daniel Lobato Garcia over 4 years ago

Fixes #7013 - pin apipie-rails to < 0.2.3

0.2.3 was released with a Ruby 1.8.7 incompatible syntax method
definition

(cherry picked from commit 33a90a9eecef8cc7105706a9d492f01d39e55b2a)

History

#1 Updated by The Foreman Bot over 4 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/1672 added
  • Pull request deleted ()

#2 Updated by Dominic Cleal over 4 years ago

  • Legacy Backlogs Release (now unused) set to 10

#3 Updated by Dominic Cleal over 4 years ago

#4 Updated by Daniel Lobato Garcia over 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF