Project

General

Profile

Bug #7095

Adding a content view to an activationkey should limit what subscriptions are available

Added by Partha Aji almost 8 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=961024
Description of problem:

If I have multiple providers with their unique products/repos and create and publish a content view that has only one of these products, when I add said content view to a new activationkey I expect that only the product added to the content view should be available to me in the Available Subscriptions tab. Currently, all products are listed as available for selection which to me is counter intuitive. I'd argue that only the one product that was added to the content view should be visible. If I removed the content view, then all available products can be displayed for selection.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:

History

#1 Updated by The Foreman Bot almost 8 years ago

  • Status changed from New to Ready For Testing
  • Target version set to 54
  • Pull request https://github.com/Katello/katello/pull/4584 added
  • Pull request deleted ()

#2 Updated by Thomas McKay almost 8 years ago

This is an RFE, not a bug. While it will be very useful to filter out subscriptions to those that match the content in the content view, there are some Red Hat subscription types that need to still be available.

1) Some subs have no content at all but instead enable other subs.
2) Sometimes it is useful to assign a sub to a hypervisor, for example, so that "bonus" subs are created which in turn may be applied to guest hosts. These hypervisors don't actually consume content and thus may be in environments w/o any.

I'd suggest some design around this feature request:

UI - Perhaps add a filter element to the subs table to switch between all or content view limited.
CLI - Perhaps arguments to reflect same filter as UI.

Could be implemented as search?

Note that there is a related concept when assigning subs to content hosts as well and same design should be applied there as well.

#3 Updated by Eric Helms almost 8 years ago

  • Status changed from Ready For Testing to Rejected
  • Triaged changed from No to Yes

#4 Updated by Eric Helms almost 8 years ago

  • Legacy Backlogs Release (now unused) set to 13

#5 Updated by Eric Helms about 7 years ago

  • Legacy Backlogs Release (now unused) deleted (13)

#6 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF