Project

General

Profile

Bug #7164

Cannot create host if the domain name starts with "."

Added by Dominic Cleal almost 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Host creation
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1131659
Description of problem:

Cannot create host if the domain name starts with "."

Version-Release number of selected component (if applicable):

How reproducible:
100%

Steps to Reproduce:
1. Create a new domain starting with "." (.mydomain.com)
2. Try to create a new host using the domain
3. webUI says invalid name

Actual results:

The webUI says the system name is invalid

Expected results:

The webUI should parse if the domain name starts with "."

Associated revisions

Revision 4717b0ea (diff)
Added by Ori Rabin almost 5 years ago

Fixes #7164: Cannot create a domain that starts or ends with '.'

History

#1 Updated by Dominic Cleal almost 5 years ago

  • Category set to Host creation

I think the domain validation should be changed to prevent users adding a leading dot (perhaps trailing too, since I'm not sure we handle that, even if it is technically correct.)

#2 Updated by Ori Rabin almost 5 years ago

  • Status changed from New to Assigned
  • Assignee set to Ori Rabin

#3 Updated by The Foreman Bot almost 5 years ago

  • Status changed from Assigned to Ready For Testing
  • Target version set to 1.7.4
  • Pull request https://github.com/theforeman/foreman/pull/1704 added
  • Pull request deleted ()

#4 Updated by Dmitri Dolguikh almost 5 years ago

  • Target version changed from 1.7.4 to 1.7.3

#5 Updated by Ori Rabin almost 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#6 Updated by Dominic Cleal almost 5 years ago

  • Legacy Backlogs Release (now unused) set to 21

Also available in: Atom PDF