Project

General

Profile

Bug #7185

search for host by included class name does not filter host results

Added by Joshua Hoblitt about 5 years ago. Updated about 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Search
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Searching from the `all hosts` page with a query like `class = mysite::foo` matches all hosts known to foreman instead of only the hosts that include the class via enc. The same problem is seen when searcing for a class name via the `puppet classes` pages and then clicking on the "number of hosts" link, which always returns a list of all hosts known to foreman.


Related issues

Is duplicate of Foreman - Bug #7035: Unable to filter on classes (v1.5.2)Closed2014-08-12

History

#1 Updated by Dominic Cleal about 5 years ago

  • Is duplicate of Bug #7035: Unable to filter on classes (v1.5.2) added

#2 Updated by Dominic Cleal about 5 years ago

  • Status changed from New to Duplicate

Thanks for the report, I think this is covered by #7035 which has a patch under review/test.

Also available in: Atom PDF