Move Ubuntu 12.04 packages to Brightbox PPA with Ruby 1.9
To drop Ruby 1.8 support and retain Ubuntu 12.04 as a supported OS, the Foreman installation will need to run under Ruby 1.9.
The Ruby 1.9.3-p0 package provided is likely to cause problems, but it could be tested (a much later patch level is what we usually test), however Puppet is known to have problems operating on p0 and so isn't supported.
Foreman should probably use the Brightbox PPA instead of 1.9.3-p0 as provided by Ubuntu 12.04.
(How Puppet will run will need to be investigated too, i.e. if the master should continue under 1.8 with Passenger 4 or similar, or if it can be loaded and run from the 1.9.3 Brightbox environment.)
refs #7227 - require Puppet 3.0.0 and Facter 1.6.12..2 builds on Ubuntu 12.04
When running Foreman or the Puppet master under Ubuntu 12.04 with the Brightbox
Ruby NG PPA, we need Puppet and Facter packaged under /usr/lib/ruby/vendor_ruby
rather than the 1.8-specific path so the 1.9 Ruby will still load them.
Distro packages and older Puppet Labs packages use the 1.8 path, which prevents
us loading these deps, so the newer packages are needed.
#1 Updated by Dominic Cleal over 8 years ago
- Blocks Tracker #4656: Drop Ruby 1.8 support added
#2 Updated by Ohad Levy over 8 years ago
- Legacy Backlogs Release (now unused) set to 21
#3 Updated by Dominic Cleal over 8 years ago
- Status changed from New to Assigned
- Assignee set to Dominic Cleal
- Target version set to 1.7.2
- Pull request https://github.com/theforeman/foreman-packaging/pull/365 added
- Pull request deleted (
Greg's made a start and has successfully built a package in Jenkins using the 1.9 PPA.
Passenger 4 is needed though to load the Foreman vhost on a different version of Ruby to Puppet, and installer, documentation and foreman-bats all need updating.
#4 Updated by Anonymous over 8 years ago
Tested the resulting .deb and it seems to work just fine with the brightbox ruby-ng ppa, once passenger-common1.9.1 got installed (that means with passenger3 and thus 1.9 enabled for all vhosts, what we don't want at the end) or also with 1:4.0.53-1~precise1 from the phusionpassenger.com repo (also still with 1.9 for all vhosts)
#5 Updated by Dominic Cleal over 8 years ago
Looks like we need to require an update to Puppet 3 and Facter 1.6.12 to make this work easily in a normal setup, else we need to add Passenger 4 into the mix, which I don't want to do by default. Puppet 3 is the lesser evil.
I've written up http://projects.theforeman.org/projects/foreman/wiki/Ubuntu_Precise_Brightbox with some user-facing docs on what we're doing and why, and will continue to expand the page.
As for tasks, I'm working on updating the installer to configure the PPA and will also investigate how easy it is to switch our shebang lines to point to 1.9, which would mean users can switch the default Ruby back to 1.8.
#6 Updated by Dominic Cleal over 8 years ago
- Status changed from Assigned to Ready For Testing
- Pull request https://github.com/theforeman/foreman-packaging/pull/394 added
- Pull request deleted (
https://github.com/theforeman/foreman-packaging/pull/394 package support
https://github.com/theforeman/puppet-foreman/pull/238 initial installer support
I'll probably separate switching the default Ruby to 1.8 to a second ticket, it's more involved.
#7 Updated by Dominic Cleal over 8 years ago
- Related to Bug #7970: Default Ubuntu 12.04 Ruby should be 1.8 added
#8 Updated by Dominic Cleal over 8 years ago
- Status changed from Ready For Testing to Closed
- % Done changed from 0 to 100
#7970 remains a blocking issue for installations I suspect.
fixes #7227 - use and require Ruby 1.9.3 from Brightbox Ruby NG PPA