Project

General

Profile

Feature #723

Hypervisor details page

Added by Dis Connect over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
VM management
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Should have list of known vms on that host (combined libvirt and foreman) with links to host pages for hosts foreman knows about)

Also a "new host" button to create a vm on that host.


Related issues

Has duplicate Foreman - Feature #734: show hypervisors detailsDuplicate2011-03-14

Associated revisions

Revision b3f525e2 (diff)
Added by Ohad Levy over 9 years ago

fixes #723 - Hypervisor details page

This also include basic functionality to power on/off guests

History

#1 Updated by Ohad Levy over 9 years ago

  • Assignee set to Ohad Levy
  • Target version set to 0.3

#2 Updated by Ohad Levy over 9 years ago

  • Status changed from New to Ready For Testing
  • % Done changed from 0 to 100

#3 Updated by Ohad Levy over 9 years ago

#4 Updated by Dis Connect over 9 years ago

Processing Hypervisors::GuestsController#index (for 10.1.2.3 at 2011-04-01 09:17:15) [GET]
Parameters: {"hypervisor_id"=>"hostfoo"}
trying to contact Hypervisor hostfoo

NoMethodError (undefined method `find_volume_by_name' for nil:NilClass):
app/models/hypervisor.rb:31:in `guests'
app/models/hypervisor.rb:65:in `query'
app/models/hypervisor.rb:31:in `guests'
app/controllers/hypervisors/guests_controller.rb:6:in `index'
/usr/lib/ruby/1.8/mongrel.rb:159:in `process_client'
/usr/lib/ruby/1.8/mongrel.rb:158:in `each'
/usr/lib/ruby/1.8/mongrel.rb:158:in `process_client'
/usr/lib/ruby/1.8/mongrel.rb:285:in `run'
/usr/lib/ruby/1.8/mongrel.rb:285:in `initialize'
/usr/lib/ruby/1.8/mongrel.rb:285

Rendering /usr/share/foreman/public/500.html (500 Internal Server Error)

#5 Updated by Ohad Levy over 9 years ago

Dis Connect wrote:

Processing Hypervisors::GuestsController#index (for 10.1.2.3 at 2011-04-01 09:17:15) [GET]
Parameters: {"hypervisor_id"=>"hostfoo"}
trying to contact Hypervisor hostfoo

NoMethodError (undefined method `find_volume_by_name' for nil:NilClass):

I can't reproduce that...

can you ensure that hostfoo does have the default storage pool? (otherwise we are hitting #720)

#6 Updated by Ohad Levy over 9 years ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF