Project

General

Profile

Bug #7321

Unable to list available subscriptions with subscription-manager < 0.96

Added by Martin Bacovsky about 7 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Client/Agent
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1136071
Description of problem:

It is not possible to list available subscriptions with older subscription-manager (probably < 0.96), RHE L5.7 and RHEL 6.1 affected.

Currently the server hits https://bugzilla.redhat.com/show_bug.cgi?id=1136056 first, but when it is fixed I'm getting:

  1. subscription-manager list --available
    Access denied

The problem is that subscription-manager is requesting wrong URL:

"GET /rhsm/pools?consumer=b9b7fd04-609c-4d5c-a382-bc0bdb5b1527 HTTP/1.1" 403 64 "-" "-"

Newer version of rhsm is requesting:

"GET /rhsm/owners/Default_Organization/pools?consumer=412a6b2a-1627-4157-a378-de4c73f14022 HTTP/1.1" 200 60043 "-" "-"

(I was not ask for org during registration)

Version-Release number of selected component (if applicable):

Satellite 6 6.0.4
Client: RHEL 5.7
subscription-manager-0.95.5.21-1.el5

How reproducible:
Always

Steps to Reproduce:
1. cold install 5.7 or 6.1
2. install bootstrap RPM from satellite server (http://sat6.example.com/pub/katello-ca-consumer-sat6.example.com-1.0-1.noarch.rpm)
3. subscription-manager register
4. subscription-manager list --available

Actual results:
Access denied

Expected results:
List of available subscriptions

Additional info:

History

#1 Updated by Eric Helms about 7 years ago

  • Category set to 125
  • Difficulty set to easy
  • Triaged changed from No to Yes

#2 Updated by Bryan Kearney over 6 years ago

  • Status changed from New to Closed

Downstream closed this bug.

#3 Updated by Eric Helms over 6 years ago

  • Legacy Backlogs Release (now unused) set to 31

Also available in: Atom PDF