Project

General

Profile

Bug #7408

hammer --help redundantly requires credentials

Added by Dominic Cleal almost 6 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Foreman commands (obsolete)
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:
In Kanboard:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1140553
Description of problem:
Running hammer --help or e.g. hammer user --help (or any other command with --help) asks for foreman credentials.

This is ridiculous, please remove it.

Version-Release number of selected component (if applicable):
rubygem-hammer_cli_foreman_tasks-0.0.3-3.el6sat.noarch
rubygem-hammer_cli_import-0.10.4-1.1.el6sat.noarch
rubygem-hammer_cli-0.1.1-12.el6sat.noarch
rubygem-hammer_cli_foreman-0.1.1-16.el6sat.noarch
rubygem-hammer_cli_katello-0.0.4-14.el6sat.noarch

How reproducible:
100%

Steps to Reproduce:
1. hammer --help
2. hammer user --help
3. hammer organization --help

Actual results:
In all above cases: "[Foreman] username:" prompt is printed out.

Expected results:
No credentials prompt to appera, but directly the help page to be printed out.

Additional info:


Related issues

Has duplicate Hammer CLI - Feature #7290: Hammer asks for credentials even when they are not actualy needed. Duplicate2014-08-28

Associated revisions

Revision 17f7cc7b (diff)
Added by Martin Bačovský over 5 years ago

Fixes #7408 - Credentials interface definition moved to ApipieBindings

Revision 20226900
Added by mbacovsky over 5 years ago

Merge pull request #150 from mbacovsky/7408_lazy_credentials

Fixes #7408 - Credentials interface definition moved to ApipieBindings

Revision 8bb69988 (diff)
Added by Martin Bačovský over 5 years ago

Fixes #7408 - Credentials definition moved to ApipieBindings

Revision e75b1cdb
Added by mbacovsky over 5 years ago

Merge pull request #156 from mbacovsky/7408_lazy_credentials

Fixes #7408 - Credentials definition moved to ApipieBindings

History

#1 Updated by Dominic Cleal almost 6 years ago

  • Category set to Foreman commands (obsolete)
  • Assignee deleted (Martin Bacovsky)

Since API doc isn't authenticated, this probably isn't necessary.

#2 Updated by The Foreman Bot over 5 years ago

  • Status changed from New to Ready For Testing
  • Target version set to 1.7.2
  • Pull request https://github.com/theforeman/hammer-cli/pull/150 added
  • Pull request deleted ()

#3 Updated by Dominic Cleal over 5 years ago

  • Has duplicate Feature #7290: Hammer asks for credentials even when they are not actualy needed. added

#4 Updated by Anonymous over 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF