Project

General

Profile

Actions

Bug #7446

closed

Deleting a foreman host doesn't clean up subscription usage

Added by Partha Aji almost 10 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Hosts
Target version:
Difficulty:
medium
Triaged:
Yes
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1140653
Description of problem:
When deleting a host through Foreman, the content host is deleted correctly but the subscription remains in use.

Version-Release number of selected component (if applicable):
6.0.4 GA (and Katello nightly)

How reproducible:
Always

Steps to Reproduce:
1. Provision a Foreman host that will have content
2. Look at 'Red Hat Subscriptions' page counts, and verify some subscriptions are in use
3. Delete the host through "All Hosts" UI
4. Confirm 'Host' and 'Content Host' are removed
5. Reload 'Red Hat Subscriptions' page

Actual results:
Subscription counts aren't updated (even after running katello:reindex)

Expected results:
Subscriptions are correctly made available

Additional info:

Actions #1

Updated by The Foreman Bot almost 10 years ago

  • Status changed from New to Ready For Testing
  • Target version set to 56
  • Pull request https://github.com/Katello/katello/pull/4666 added
  • Pull request deleted ()
Actions #2

Updated by Eric Helms almost 10 years ago

  • Category set to 83
  • Difficulty set to medium
  • Triaged changed from No to Yes
Actions #3

Updated by Partha Aji almost 10 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100
Actions #4

Updated by Eric Helms over 9 years ago

  • Translation missing: en.field_release set to 14
Actions

Also available in: Atom PDF