Project

General

Profile

Feature #7495

Support for adding autosign entries via API

Added by Anonymous almost 7 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Low
Category:
API
Target version:
Difficulty:
Triaged:
Bugzilla link:

Description

While it's possible to add autosign entires via WebUI, the API has only a GET method for the entries. It would be nice to be able to add autosign entires also via API.


Related issues

Related to Foreman - Feature #4986: API Does not allow Puppet certificate revocation/cleanNew
Blocks Hammer CLI - Feature #18531: Add commands for autosign entriesNew

Associated revisions

Revision 0b22ca40 (diff)
Added by Ondřej Pražák over 4 years ago

Fixes #7495 - Create/delete autosign entries via API

Revision b3566844 (diff)
Added by Dominic Cleal over 4 years ago

refs #7495 - correct syntax in API error handler

History

#1 Updated by Dominic Cleal almost 7 years ago

  • Is duplicate of Feature #4986: API Does not allow Puppet certificate revocation/clean added

#2 Updated by Dominic Cleal almost 7 years ago

  • Status changed from New to Duplicate

#3 Updated by Dominic Cleal almost 7 years ago

  • Is duplicate of deleted (Feature #4986: API Does not allow Puppet certificate revocation/clean)

#4 Updated by Dominic Cleal almost 7 years ago

  • Related to Feature #4986: API Does not allow Puppet certificate revocation/clean added

#5 Updated by Dominic Cleal almost 7 years ago

  • Status changed from Duplicate to New
  • Bugzilla link set to 1140671

#6 Updated by Ondřej Pražák over 4 years ago

  • Assignee set to Ondřej Pražák

#7 Updated by Ondřej Pražák over 4 years ago

#8 Updated by The Foreman Bot over 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/4292 added

#9 Updated by Anonymous over 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#10 Updated by The Foreman Bot over 4 years ago

  • Pull request https://github.com/theforeman/foreman/pull/4304 added

#11 Updated by Dominic Cleal over 4 years ago

  • Legacy Backlogs Release (now unused) set to 209

Also available in: Atom PDF