Project

General

Profile

Bug #7535

Failed puppet module uploads still report success, no explanation given

Added by Chris Pitman over 7 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Repositories
Target version:
Difficulty:
easy
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

I am trying to upload a custom puppet module I have developed. Via both hammer and the GUI the upload "succeeds" but no puppet module appears to be in the repository. The module is not present in the pulp content.

Uploading works fine for puppetlabs-stdlib, so I assume the issue is related to the module. Regardless, if a user uploads a module and no module is found, an error should be reported with guidance on why it may be failing.

The same behavior can be seen if a "zip" is uploaded instead of a "tar.gz". The upload "succeeds", but nothing actually happens. I've attached a stdlib zip to reproduce.

puppetlabs-stdlib-master.zip puppetlabs-stdlib-master.zip 252 KB Chris Pitman, 09/18/2014 02:53 PM

History

#1 Updated by Eric Helms over 7 years ago

  • Difficulty set to easy
  • Triaged changed from No to Yes

#2 Updated by Eric Helms over 6 years ago

  • Status changed from New to Resolved

#3 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF