Project

General

Profile

Bug #7579

Session reset after each page request, idle_timeout set to zero

Added by Dominic Cleal over 4 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Settings
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Multiple reports on Ubuntu 14.04 that on a clean installation, web UI sessions are reset after every single request.

This appears to be caused by an idle_timeout set to zero.

As a workaround, go to Administer > Settings > General and set idle_timeout to 60 or similar.


Related issues

Related to Foreman - Bug #6537: Entering a very large number for idle_timeout is unchecked, crashes UIClosed2014-07-09
Related to Foreman - Bug #8294: Warning! InfinityResolved2014-11-05
Related to Foreman - Bug #8657: Request timeout when registering smart proxy during installation due tu proxy_request_timeout=0Duplicate2014-12-10

History

#2 Updated by Dominic Cleal over 4 years ago

  • Related to Bug #6537: Entering a very large number for idle_timeout is unchecked, crashes UI added

#3 Updated by Dominic Cleal over 4 years ago

  • Target version set to 1.7.3
  • Legacy Backlogs Release (now unused) set to 22

#4 Updated by Dmitri Dolguikh over 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Dmitri Dolguikh

#5 Updated by Dmitri Dolguikh over 4 years ago

  • Status changed from Assigned to Need more information

Can't reproduce based on currently available information. Would be useful to know:
- if the installer was used (if not, how install was performed)
- what installer options were used
- maybe even step-by-step description of the install?

#6 Updated by Dominic Cleal over 4 years ago

  • Legacy Backlogs Release (now unused) deleted (22)

#7 Updated by Dominic Cleal over 4 years ago

  • Assignee deleted (Dmitri Dolguikh)
  • Target version deleted (1.7.3)

#8 Updated by Matt Darcy over 4 years ago

This issue is not related to just ubuntu 14.04.

I hit this problem with CentOS 6.4 x86_64 using Foreman 1.6.2

I installed Centos 6.5 minimal install.

Added the SCL/EPEL/Puppetlabs/Foreman repos and updated my yum metadata.

I installed dhcp-server, tftp-server, puppet-server and foreman-installer (with associated dependency packages)

I used the following foreman installation line.

--enable-foreman-compute-libvirt --foreman-db-host localhost --foreman-proxy-dhcp-interface eth1 --foreman-db-type mysql

the installer appeared to complete without error (the error log confirms this)

but the timeout parameter was set to 0. Setting this to a higher number resolved the issue.

#9 Updated by Matt Darcy over 4 years ago

I should point out that I hit this issue on a clean install after hitting problems with the ruby "facter hostname" not being able to set/detect the fqdn.

#10 Updated by Nate Walck over 4 years ago

I just did a fresh spinup using the puppet-foreman module and ran into this issue.

OS: 14.04 LTS
Foreman: 1.6.1
Module: puppet-foreman

I included the module and set the one time admin_password var, otherwise no modifications.

idle timeout defaulted to 0 seconds, changing it to 3600 prevented the instant page timeouts.

#11 Updated by Dominic Cleal over 4 years ago

  • Related to Bug #8294: Warning! Infinity added

#12 Updated by Dominic Cleal over 4 years ago

I just hit the same issue with Ubuntu 14.04 in 1.8 nightlies. The installation took a very long time, but I suspect that's related to API locale changes (https://github.com/theforeman/foreman/commit/a59972c3).

root@foremandeb:~# sudo -H -u foreman /usr/share/foreman/script/foreman-config
foreman-config script is deprecated. Please consider using `foreman-rake config` instead
[deprecated] I18n.enforce_available_locales will default to true in the future. If you really want to skip validation of your locale you can set I18n.enforce_available_locales = false to avoid this message.
Workaround for RbVmomi may not work as ComputeResource is already loaded: ComputeResource
administrator:
authorize_login_delegation: false
authorize_login_delegation_api: false
authorize_login_delegation_auth_source_user_autocreate:
bootdisk_cache_media: true
bootdisk_generic_host_template: Boot disk iPXE - generic host
bootdisk_host_template: Boot disk iPXE - host
bootdisk_ipxe_dir: /usr/lib/ipxe
bootdisk_mkiso_command: genisoimage
bootdisk_syslinux_dir: /usr/lib/syslinux
create_new_host_when_facts_are_uploaded: true
create_new_host_when_report_is_uploaded: true
db_pending_migration: false
db_pending_seed: false
default_location:
default_organization:
default_puppet_environment: production
Default_variables_Lookup_Path: ["fqdn","hostgroup","os","domain"]
document_root: /usr/share/foreman/public/puppet/rdoc
email_reply_address:
Enable_Smart_Variables_in_ENC: true
enc_environment: true
entries_per_page: 0
fix_db_cache: false
foreman_url: https://foremandeb.example.com
host_group_matchers_inheritance: true
idle_timeout: 0
ignore_puppet_facts_for_provisioning: false
interpolate_erb_in_parameters: true
legacy_puppet_hostname: false
libvirt_default_console_address: 0.0.0.0
location_fact: foreman_location
login_delegation_logout_url:
manage_puppetca: true
max_trend: 0
modulepath: /etc/puppet/modules
oauth_active: true
oauth_consumer_key: xUpD4TCCgFTpFNsWFvPT98UMGZyXbhL7
oauth_consumer_secret: Z5uk2tjeRPWRuWJv7UAWj4fJqC3C4hTQ
oauth_map_users: false
organization_fact: foreman_organization
Parametrized_Classes_in_ENC: true
proxy_request_timeout: 0
puppet_interval: 0
puppetrun: false
puppet_server: puppet
query_local_nameservers: false
remote_addr: 127.0.0.1
require_ssl_puppetmasters: true
restrict_registered_puppetmasters: true
root_pass:
safemode_render: true
send_welcome_email: false
ssl_ca_file: /var/lib/puppet/ssl/certs/ca.pem
ssl_certificate: /var/lib/puppet/ssl/certs/foremandeb.example.com.pem
ssl_client_dn_env: SSL_CLIENT_S_DN
ssl_client_verify_env: SSL_CLIENT_VERIFY
ssl_priv_key: /var/lib/puppet/ssl/private_keys/foremandeb.example.com.pem
token_duration: 0
trusted_puppetmaster_hosts: []
unattended_url: http://foremandeb.example.com
update_environment_from_facts: false
update_ip_from_built_request: false
use_gravatar: true
use_shortname_for_vms: false
use_uuid_for_certificates: false
websockets_encrypt: true
websockets_ssl_cert: /var/lib/puppet/ssl/certs/foremandeb.example.com.pem
websockets_ssl_key: /var/lib/puppet/ssl/private_keys/foremandeb.example.com.pem

Note that all integer settings are zero. The installation was simply with foreman-installer --foreman-admin-password=XXX, default settings otherwise, including PostgreSQL.

I did try accessing the login page towards the end of the installation while it was still installing either bootdisk or foreman_setup.

#13 Updated by John Brooker over 4 years ago

+1 . issue occurred with a default 14.04 installation with no flags.

#14 Updated by Tomer Paz over 4 years ago

happened to me too, consistently running on docker, Foreman 1.6.3
Can't change the idle_timeout from GUI since egg/chicken scenario - can't login, 'session expires' (tried on FF and Chrome).
What's the CLI so I can change the idle_timeout from 0?
the only other option for me is to trace down this field in the PostgreSQL DB and alter it manually

#15 Updated by Dominic Cleal over 4 years ago

sudo -u foreman /usr/share/foreman/script/foreman-config -k idle_timeout -v 60 should do it.

#16 Updated by Dominic Cleal over 4 years ago

  • Related to Bug #8657: Request timeout when registering smart proxy during installation due tu proxy_request_timeout=0 added

#17 Updated by Dominic Cleal over 4 years ago

We're just releasing Foreman 1.7.1 which contains a fix for a similar issue (#7353). There's a possibility that it's the same bug, so if anybody sees this again with foreman-installer 1.7.1, I'd really like to know, just to rule it out.

#18 Updated by Gavin Williams about 4 years ago

I just hit the same issue with a fresh CentOS 6 install using Foreman-installer 1.7.2.

Running sudo -u foreman /usr/share/foreman/script/foreman-config -k idle_timeout -v 60 fixed it...

#19 Updated by Dominic Cleal about 4 years ago

  • Status changed from Need more information to Feedback

Thanks for the update, we had some additional changes to the installer in 1.8, so if anybody hits this on 1.8, we can re-open.

#20 Updated by Michael Moll about 2 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF