Project

General

Profile

Bug #7582

Weirdness when upgrading foreman-proxy: 1.5.2-1 -> 1.6.0-1

Added by David Schmitt over 7 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Debian/Ubuntu
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

When upgrading foreman-proxy from 1.5.2-1 to 1.6.0-1 on Debian wheezy, the following message is displayed:

Preparing to replace foreman-proxy 1.5.2-1 (using .../foreman-proxy_1.6.0-1_all.deb) ...
[ ok ] Stopping foreman-proxy (via systemctl): foreman-proxy.service.
cp: `/usr/share/foreman-proxy/config/settings.yml' and `/etc/foreman-proxy/settings.yml' are the same file
Unpacking replacement foreman-proxy ...

This is probably because of

root@puppetmaster:~# readlink -f /usr/share/foreman-proxy/config/settings.yml 
/etc/foreman-proxy/settings.yml

History

#1 Updated by Anonymous almost 6 years ago

  • Status changed from New to Resolved

While reproducible with the versions given, this can't been seen with higher versions.

Also available in: Atom PDF