Project

General

Profile

Bug #7624

location and organization char names are capped to 246 instead of 255

Added by Ori Rabin almost 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1123818
Description of problem:

Unable to create loccation names with char limit of 255.

We face PGError, when creating names more than 246 chars.

Version-Release number of selected component (if applicable):
sat6-GA-snap2

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

We have the below 2 issues:

a) Unable to create locations name with 255 chars, currently capped to 246chars.
b) The location name field, should display "cannot create name with more than 255 chars", instead of te PGError.

Expected results:
We need the fix for both the below issues.

a) location name field needs to accept upto 255 chars.
b) Instead of dispaying the PGError, the UI needs to handle it and display "mot more than 255 chars" for more than 255 char limit.

Additional info:


Related issues

Related to Foreman - Bug #7038: PGError when hostgroup name exceeds 245 charactersClosed2014-08-12
Related to Foreman - Refactor #7439: Host group name limited because lookup_value 'match' is a stringNew2014-09-15
Related to Foreman - Bug #13378: Two error messages for too long name on location or organization creationClosed2016-01-26

Associated revisions

Revision e7fe0b7d (diff)
Added by Ori Rabin almost 5 years ago

Fixes #7624: validation for location and organization long names instead of an error

History

#1 Updated by Ori Rabin almost 5 years ago

  • Status changed from New to Assigned

This issue was fixed for host name but not for location

PG::StringDataRightTruncation: ERROR: value too long for type character varying(255)
: UPDATE "lookup_values" SET "match" = 'location=DDVROq3fXzO24DcjDcxaC6x5QVA8FHQpCJtSdtWzagWzSoiBMrxDfLFPC1o0XgvI59F0a8O7RtlrAudYNADknKMvTP7A3FRSvZ77CLmbsIv7bG2bv7ZVgi29ERZWDAsYRAP4xDDZwRvnJsGCBaYvK5fX6ilA6exksUMfrTLqm86gQPSrMgcULAh1KR5NZfvir1XCtU9Xxeh4vzrjubsmk9bKn0DFgXe5N3L8i5x0LPuvK7ABSztbHaw' WHERE "lookup_values"."match" = 'location='

#2 Updated by Ori Rabin almost 5 years ago

  • Related to Bug #7038: PGError when hostgroup name exceeds 245 characters added

#3 Updated by Ori Rabin almost 5 years ago

  • Related to Refactor #7439: Host group name limited because lookup_value 'match' is a string added

#4 Updated by Ori Rabin almost 5 years ago

  • Subject changed from location char name is capped to 246 instead of 255 to location and organization char names are capped to 246 instead of 255

#5 Updated by The Foreman Bot almost 5 years ago

  • Status changed from Assigned to Ready For Testing
  • Target version set to 1.7.3
  • Pull request https://github.com/theforeman/foreman/pull/1803 added
  • Pull request deleted ()

#6 Updated by Dominic Cleal almost 5 years ago

  • Target version changed from 1.7.3 to 1.7.2

#7 Updated by Ori Rabin almost 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#8 Updated by Daniel Lobato Garcia almost 5 years ago

  • Legacy Backlogs Release (now unused) set to 21

#9 Updated by Dominic Cleal over 3 years ago

  • Related to Bug #13378: Two error messages for too long name on location or organization creation added

Also available in: Atom PDF