Project

General

Profile

Bug #7629

katello-agent/goferd: No module named bindings.server on package install

Added by Justin Sherrill over 7 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Category:
Client/Agent
Target version:
Difficulty:
medium
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Hello,

it seems there are some issue with the "katello-agent/goferd" on Katello 2.0 RC1, below the details:

#Issue1-EL6: "Non-fatal POSTIN scriptlet failure" during Kickstart Post-Install of katello-agent
#Issue2-EL6: "goferd" errors in messages during "service goferd start"
#Issue3-EL6: "Push Install Package" from Katello Server to EL6 Client is not performed, task is hanging on running/pending for ages (I think its related to the above issues)
#Issue4-EL7: "Push Install Package" from Katello Server to EL7 Client is performed ok, but Error in messages file is visible (not sure if it has a side effect)

*Issue1-EL6 ###
Starting goferdTraceback (most recent call last):
File "/usr/bin/goferd", line 17, in <module>
from gofer.agent.main import main
File "/usr/lib/python2.6/site-packages/gofer/agent/main.py", line 26, in <module>
LogHandler.install()
File "/usr/lib/python2.6/site-packages/gofer/agent/logutil.py", line 44, in install
handler = LogHandler(address='/dev/log', facility=SysLogHandler.LOG_DAEMON)
File "/usr/lib64/python2.6/logging/handlers.py", line 721, in init
self._connect_unixsocket(address)
File "/usr/lib64/python2.6/logging/handlers.py", line 737, in _connect_unixsocket
self.socket.connect(address)
File "<string>", line 1, in connect
socket.error: [Errno 111] Connection refused

*Issue2-EL6 ###
Sep 20 13:16:39 centos-6 goferd: [INFO][MainThread] gofer.agent.plugin:521 - plugin [builtin] loaded using: /usr/share/gofer/plugins/builtin.py
Sep 20 13:16:39 centos-6 goferd: [ERROR][MainThread] gofer.agent.plugin:535 - plugin "katelloplugin", import failed
Sep 20 13:16:39 centos-6 goferd: [ERROR][MainThread] gofer.agent.plugin:535 - Traceback (most recent call last): File "/usr/lib/python2.6/site-packages/gofer/agent/plugin.py", line 519, in _import plugin.impl = imp.load_source(name, path) File "/usr/lib/gofer/plugins/katelloplugin.py", line 33, in <module> from subscription_manager.certlib import ConsumerIdentity ImportError: cannot import name ConsumerIdentity
Sep 20 13:16:39 centos-6 goferd: [INFO][Actions] builtin:38 - Hello: [main] enabled=1 [messaging] url= uuid=
Sep 20 13:16:39 centos-6 goferd: [INFO][MainThread] gofer.agent.main:136 - agent started.

*Issue3-EL6
"start_time"=>nil,
"state"=>"waiting"
3: Actions::Pulp::Consumer::ContentInstall (suspended) [ 1088.36s / 2.54s ]

*Issue4-EL7 ###
Sep 20 14:05:59 centos-7 goferd: [ERROR][worker-0] pulp.agent.lib.container:303 - handler "bind", import failed
Sep 20 14:05:59 centos-7 goferd: [ERROR][worker-0] pulp.agent.lib.container:303 - Traceback (most recent call last): File "/usr/lib/python2.7/site-packages/pulp/agent/lib/container.py", line 297, in load mod = self.__import_module(path) File "/usr/lib/python2.7/site-packages/pulp/agent/lib/container.py", line 326, in __import_module mod = __import(path0, globals(), locals(), [path[-1]]) File "/usr/lib/python2.7/site-packages/pulp_rpm/handlers/bind.py", line 9, in <module> from pulp_rpm.handlers import repolib File "/usr/lib/python2.7/site-packages/pulp_rpm/handlers/repolib.py", line 12, in <module> from pulp.bindings.server import DEFAULT_CA_PATH ImportError: No module named bindings.server

best regards,
Christian

Cloning to handle the "No module named bindings.server" error


Related issues

Copied from Katello - Bug #7553: katello-agent/goferd: plugin "katelloplugin" import failed - cannot import name ConsumerIdentity on EL6 / No module named bindings.server on EL7Closed2014-09-20

History

#1 Updated by Justin Sherrill over 7 years ago

  • Copied from Bug #7553: katello-agent/goferd: plugin "katelloplugin" import failed - cannot import name ConsumerIdentity on EL6 / No module named bindings.server on EL7 added

#2 Updated by Justin Sherrill over 7 years ago

Christian,

So i am able to reproduce the issue, however my installation actually works fine. I installed and removed a package a bunch of times and the process actually completed just fine. I do see that traceback. Can you confirm that it is working for you?

-Justin

#3 Updated by Christian Ehart over 7 years ago

Push Install/Removal works fine, only the error in messages is visible (thats the reason why I wrote: not sure if it has a side effect). Its up to you to handle/fix it or to close it as "worked as designed for example"...

#4 Updated by Justin Sherrill over 7 years ago

  • Status changed from New to Rejected

Ahhhh, I missed that subtlety in your original issue. I have filed an upstream issue: https://bugzilla.redhat.com/show_bug.cgi?id=1146294 against pulp as their packaging is the cause that we are seeing this (and how it interacts with katello-agent).

I will go ahead and close this as 'rejected' since there is no fix on the katello side for this. Thanks for reporting this though!

#5 Updated by Eric Helms about 7 years ago

  • Legacy Backlogs Release (now unused) deleted (13)

#6 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF