Project

General

Profile

Bug #7817

pulp-manage-db fails during capsule-installer

Added by b sh about 7 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Foreman Proxy Content
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Hi,

When running
capsule-installer --parent-fqdn "$SATELLITE_FQDN"
--register-in-foreman "true"
--foreman-oauth-key "$FOREMAN_OAUTH_KEY"
--foreman-oauth-secret "$FOREMAN_OAUTH_SEC"
--pulp-oauth-secret "$PULP_OAUTH_SECRET"
--certs-tar "/root/$CAPSULE_FQDN-certs.tar"
--puppet "true"
--puppetca "true"
--pulp "true"
--tftp "true"

I get the following error(s):
pulp-manage-db && touch /var/lib/pulp/init.flag returned 70 instead of one of [0]
/Stage[main]/Pulp::Config/Exec[migrate_pulp_db]/returns: change from notrun to 0 failed: pulp-manage-db && touch /var/lib/pulp/init.flag returned 70 instead of one of [0]

History

#1 Updated by b sh about 7 years ago

from /var/log/katello-installer/capsule-installer.log:

[DEBUG 2014-10-05 15:00:31 main] Exec[migrate_pulp_db](provider=posix): Executing 'pulp-manage-db && touch /var/lib/pulp/init.flag'
[DEBUG 2014-10-05 15:00:31 main] Executing 'pulp-manage-db && touch /var/lib/pulp/init.flag'
[ WARN 2014-10-05 15:00:32 main] /Stage[main]/Pulp::Config/Exec[migrate_pulp_db]/returns: /usr/lib/python2.6/site-packages/pulp/server/db/connection.py:133: DeprecationWarning: The safe parameter is deprecated. Please use write concern options instead.
[ WARN 2014-10-05 15:00:32 main] /Stage[main]/Pulp::Config/Exec[migrate_pulp_db]/returns: return method(*args, **kwargs)
[ WARN 2014-10-05 15:00:32 main] /Stage[main]/Pulp::Config/Exec[migrate_pulp_db]/returns: Applying migration pulp.server.db.migrations.0009_qpid_queues failed.
[ WARN 2014-10-05 15:00:32 main] /Stage[main]/Pulp::Config/Exec[migrate_pulp_db]/returns:
[ WARN 2014-10-05 15:00:32 main] /Stage[main]/Pulp::Config/Exec[migrate_pulp_db]/returns: Halting migrations due to a migration failure. See log for details.
[ WARN 2014-10-05 15:00:32 main] /Stage[main]/Pulp::Config/Exec[migrate_pulp_db]/returns: [Errno 1] _ssl.c:492: error:14094418:SSL routines:SSL3_READ_BYTES:tlsv1 alert unknown ca
[ WARN 2014-10-05 15:00:32 main] /Stage[main]/Pulp::Config/Exec[migrate_pulp_db]/returns: Loading content types.
[ WARN 2014-10-05 15:00:32 main] /Stage[main]/Pulp::Config/Exec[migrate_pulp_db]/returns: Content types loaded.
[ WARN 2014-10-05 15:00:32 main] /Stage[main]/Pulp::Config/Exec[migrate_pulp_db]/returns: Ensuring the admin role and user are in place.
[ WARN 2014-10-05 15:00:32 main] /Stage[main]/Pulp::Config/Exec[migrate_pulp_db]/returns: Admin role and user are in place.
[ WARN 2014-10-05 15:00:32 main] /Stage[main]/Pulp::Config/Exec[migrate_pulp_db]/returns: Beginning database migrations.
[ WARN 2014-10-05 15:00:32 main] /Stage[main]/Pulp::Config/Exec[migrate_pulp_db]/returns: Applying pulp.server.db.migrations version 9
[ERROR 2014-10-05 15:00:32 main] pulp-manage-db && touch /var/lib/pulp/init.flag returned 70 instead of one of [0]

#2 Updated by Eric Helms about 7 years ago

  • Legacy Backlogs Release (now unused) set to 24
  • Triaged changed from No to Yes

#3 Updated by Eric Helms almost 7 years ago

  • Legacy Backlogs Release (now unused) changed from 24 to 14

#4 Updated by Eric Helms almost 7 years ago

  • Legacy Backlogs Release (now unused) changed from 14 to 23

#5 Updated by Eric Helms over 6 years ago

  • Status changed from New to Need more information
  • Target version set to 67

I have not been able to reproduce this. Do you still hit this issue? Could you generate and point me at a foreman-debug if you are?

#6 Updated by Eric Helms over 6 years ago

  • Target version changed from 67 to 68

#7 Updated by Eric Helms over 6 years ago

  • Status changed from Need more information to Resolved
  • Target version deleted (68)
  • Legacy Backlogs Release (now unused) deleted (23)

Closing as resolved without further information and not being able to replicate. If you run into this issue again, please re-open and we will happily tackle it. Thanks!

#8 Updated by Eric Helms over 5 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF