Project

General

Profile

Bug #7851

Long smart class parameters and values gets truncated in foreman "Parameters" section

Added by Petter Hassberg over 5 years ago. Updated over 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Although there is plenty of space on both sides of the table of the "Parameters" section when editing a host or hostgroup in the foreman UI, parameters with long names gets truncated, scrolling vertically in these input fields to reveal the names of these params is an inconvenicence, and increases risk of wrong parameter ending up associated with wrong value, as it is really hard to get an overview when you can't see from that view the overridden values mapped to their corresponding values.

Specifically the "Parameter name" field is an issue. The:

<input class="form-control" data-property="name" disabled="disabled" id="" name="" title="Parameter name" type="text" value="">

Consider for example these two smart class parameters: "multicast_address_cache" and "multicast_address_cluster": If you override both of them in your hostgroup, then scroll down to the "Host Parameters", on the left hand side, there will be two lines of "multicast_address" with rest of name truncated.


Related issues

Is duplicate of Foreman - Bug #11371: Smart variables are not truncated in host edit formClosed2015-08-16

History

#1 Updated by Tomer Brisker over 4 years ago

  • Is duplicate of Bug #11371: Smart variables are not truncated in host edit form added

#2 Updated by Tomer Brisker over 4 years ago

  • Status changed from New to Duplicate

closing as duplicate, should be fixed now in nightly. Please reopen if not.

Also available in: Atom PDF